Страницы: 1
RSS
Как "заставить" СЧЁТЕСЛИ считать "1" и не считать "001"
 
В массиве есть числа 1 (единицы), а есть нечисла, которые записаны вот так ="001". СЧЁТЕСЛИ(диапазон;"001") считает и обычные единицы, и "001", что по замыслу неправильно. Вопрос: как заставить счётесли считать только по критерию "001" (при условии, что в массиве могут быть также 1 - единицы)
 
Опять вместо Вас пример создавать и название темы корректировать...

Почему не подходит СЧЕТ? Под Ваше описание - самое то.
Нужно видеть, что там у Вас в диапазоне понатыкано.
 
сорри, вот пример:
СЧЁТ не подойдет т.к. кроме упомянутых значений может быть также и "002" и т.д...
 
СЧЕТЕСЛИ, похоже, никак не заставить, а вот младшая сестричка может:
=СЧЁТЕСЛИМН($B$2:$B$15;E2;$B$2:$B$15;"<>*")
 
для единицы в примере (в файле-пример) эта формула посчитала правильно, вернула в качестве результата 7, а вот для "001" - нет (результат тоже 7), и для "002" тоже не то - 0 (вместо 3)
(
 
Все эти функции пытаются привести критерий и массив значений к типу. Т.е. 001 будет успешно приведено к числовому типу и в результате будет 1.
Выход только один:
=СУММПРОИЗВ(--(E2=$B$2:$B$15))
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Для ленивых - сводная... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Цитата
The_Prist написал: =СУММПРОИЗВ(--(E2=$B$2:$B$15))
Как я сам не додумался?! ))
Спасибо! Работает! )
 
Zhukov_K, а как Вы не додумались теме дать правильное название?!
Цитата
Вопрос: как заставить счётесли считать только по критерию "001" (при условии, что в массиве могут быть также 1 - единицы)
Вопрос четкий, о конкретной функции! Если проблема в подсчете, то почему так и не пишете?
 
Цитата
Zhukov_K написал: для единицы в примере (в файле-пример) эта формула посчитала правильно, вернула в качестве результата 7, а вот для "001"
Вторую формулу не писал, посчитал, что за столько времени на форуме приобрели достаточно знаний. Ошибся...
Для числовых значений - не равно тексту, для текста - равно тексту:
"=*"
=СЧЁТЕСЛИМН($B$2:$B$15;E2;$B$2:$B$15;"=*")
 
Цитата
vikttur написал: Вопрос четкий, о конкретной функции
Да, думалось, что СЧЁТЕСЛИ все же справится с этой задачей. Если же не справляется, то иного выхода нет кроме как использовать альтернативные решения.
Цитата
vikttur написал: Вторую формулу не писал
Конечно, мог бы я догадаться, Вы верно предположили, но если в эту тему забредет кто не так долго на форуме, то может и на разберется
 
Еще раз: название темам нужно давать по задаче, а не по своим возможным решениям. Иначе так и будет: получите ответ "нет", хотя альтернативные решения есть
Страницы: 1
Читают тему (гостей: 1)
Наверх