Страницы: 1
RSS
Формула с функционалом наподобие ОКРУЛТВВЕРХ
 
Всем добра!!!
Как изловчится и написать формулу, которая бы округляла всегда вверх и при этом имела функционал как ОКРУГЛТ ?
Вот, если взять несколько чисел, каждое из которых должно быть округлено в большую сторону и при этом кратно 50:
1-й столбик - число, второй - то, что должно получиться:

23 - 50
156 - 200
120 - 150
204 - 250
490 - 500

и т.д.
 
Код
=(ОТБР(A1/50)+1)*50
 
В 2010 есть такая функция, которая это выполняет.
Код
=ОКРВВЕРХ.ТОЧН(A1;50)
 
Цитата
Kuzmich написал: =(ОТБР(A1/50)+1)*50
Да, то что надо! )) Но... она немного некорректно работает.. ) Для случая 200, например, она вернет 250.. что не совсем, скажем так, правильно.. )
 
Цитата
Zhukov_K написал: она немного некорректно работает
Попробуйте так
Код
=(ОТБР(A1/50)+(ОСТАТ(A1;50)>0))*50
Изменено: gling - 30.10.2016 00:20:05
 
Цитата
gling написал: =ОКРВВЕРХ.ТОЧН(A1;50)
Супер! Да, она делает то, что надо.. Но вопрос такой, странно, однако, при вводе =ОКР.. эксель не выдает в перечне предлагаемых функций ОКРВВЕРХ.ТОЧН
С чем это может быть связано? (

Изменено: Zhukov_K - 30.10.2016 00:20:14
 
Код
=ЕСЛИ(ОСТАТ(A5;50)=0;A5;(ОТБР(A5/50)+1)*50)
 
Сокращение формулы от Kuzmich:
=(ОТБР(A5/50)+(ОСТАТ(A5;50)<>0))*50

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Цитата
gling написал: В 2010 есть такая функция

Цитата
Zhukov_K написал: эксель не выдает в перечне
А у Вас точно (ОКРВВЕРХ.ТОЧН  :D) 2010-й или младше?
Согласие есть продукт при полном непротивлении сторон.
 
Цитата
Sanja написал:
А у Вас точно 2010-й или младше?
Это 2016. Zhukov_K, если подвести курсор к ОКРВВЕРХ.МАТ, то увидим
 
Вот еще, на всякий случай:
=A3-ОСТАТ(A3;-50)
 
Zhukov_K, спасибо за интересное решение. :)

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
Win7, Office 2013
ОКРВВЕРХ.ТОЧН не виден в списке, но если написать вручную - работает.
Страницы: 1
Читают тему (гостей: 1)
Наверх