Страницы: 1
RSS
Поиск значения массива, соответствующего условию
 
Здравствуйте!
Имеется таблица следующего типа:
КомпанияОборот отОборот доНомер
Рога130
Рога381
Рога8102
Рога10113
Копыта1106
Копыта10206
Задача - найти максимальный элемент "Номер", у которого будет значение компании "Рога", и дополнительно заданное значение оборота, например 4, будет попадать в интервал [Оборот от;Оборот до). В данном случае это будет значение "1" на второй строке. Пробовал использовать формулу:
Код
{=ИНДЕКС(Таблица;МАКС(ЕСЛИ(И("Рога"=Таблица;4>=Оборот от;4<Оборот до);СТРОКА(Номер);0));4)}
Не уверен, насколько написанное корректно. Насколько я понимаю, не работает из-за того, что одно значение "Рога" сравнивается со всем массивом. Пример в приложении. В каком направлении работать - может справится ВПР? Заранее спасибо!
 
=АГРЕГАТ(15;6;$D$2:$D$7/($A$2:$A$7="Рога")/($B$2:$B$7<=4)/($C$2:$C$7>4);1)

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Страницы: 1
Читают тему (гостей: 1)
Наверх