Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск текста в диапазоне данных, И возврат "+" если такой имеется
 
Приветствую всех. Пример прикрепил. Имеем таблицу с данными, где в ячейках написано имя и фамилию через точку. Как произвести поиск по фамилии в диапазоне и вернуть "+" в итоговую таблицу, если такое имя имеется.
 
макрос..
 
Вариант:
1. Штатный режим: Данные (Текст по столбцам) с разделителем ".";
2. Традиционный поиск - функция ВПР.
 
Формула:
Код
=ЕСЛИ(СЧЁТЕСЛИ(G$1:G$4;"*."&A1);"+";"-")
Изменено: DV - 15 Июл 2013 04:14:52
 
Код
=ТЕКСТ(СЧЁТЕСЛИ($G$1:$G$4;"*"&A1);"+;;-")
 
Михаил С.,
вау! объясните пожалуйста последнее чудо "+;;-" - как это работает? это сокращенная версия функции ЕСЛИ?!

k61,
пока не доходят руки до макросов, хотя когда-то в лицее дружил с программированием. спасибо

Мотя,
штатный режим не подходит, так как сам это могу, но придется много потеть , так как таблица в которой ищу - изменяется и обновляется из инета.

Всем огромное спасибо,
Просидел вчера часиков так 2 с извращением формул. Даже счетесли просматривал, но не додумался.

Усложнить формулу,
Господа, а как попросить Эксель искать имя и перед точкой и после точки?
То есть ставить "+" для "Ира" и в случае "Ира.Федотова" и в случае "Федотова.Ира"
Изменено: alexhorse - 15 Июл 2013 11:38:44
 
Цитата
вау! объясните пожалуйста последнее чудо "+;;-" - как это работает? это сокращенная версия функции ЕСЛИ?!
Нет, это формат такой. Попробуйте на несколько ячеек задать такой формат и поиграйтесь, вводя в эти ячейки "Положительные числа;Отрицательные числа;Ноль".
Цитата
Господа, а как попросить Эксель искать имя и перед точкой и после точки?
То есть ставить "+" для "Ира" и в случае "Ира.Федотова" и в случае "Федотова.Ира"
Код
=ТЕКСТ(СЧЁТЕСЛИ($G$1:$G$4;"*."&A1)+СЧЁТЕСЛИ($G$1:$G$4;A1&".*");"+;;-")
 
Спасибо.

Почему не хочет работать такой вариант:
=ЕСЛИ(СЧЁТЕСЛИ($G$1:$G$4;ИЛИ(A1&".*";"*."&A1));"+";"-")

Можно ли в конце таблицы в ячейке выводить те новые имена или фамилии, которых нет в сводном списке? То есть Эксель проверяет сводный список с обновляемым и тогда выдает то чего нет в сводном.
Прикрепил пример.
 
Цитата
alexhorse пишет:
Почему не хочет работать такой вариант:
=ЕСЛИ(СЧЁТЕСЛИ($G$1:$G$4;ИЛИ(A1&".*";"*."&A1));"+";"-")
глупость... кхгм... неправильность выделена красным.
внимательно почитайте справку по логической функции ИЛИ.
и подумайте - применима ли логическая функция к символьным аргументам?

пс. Вам же Алишер написал формулу с разделенными СЧЁТЕСЛИ.
не зря, наверное?
или Вы полагаете - ему оплата посимвольная идёт?
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
достаточно так: счетесли(($G$1:$G$4;"*"&A1&"*") ; не понятно, зачем нужна точка.
 
Можно ли создать тему с новым вопросом? Можно [МОДЕРАТОР]
Страницы: 1
Читают тему (гостей: 1)
Наверх