Страницы: 1
RSS
Индивидуальная нумерация для каждого нового значения в столбце, Ищу способ как задать нумерацию в столбце отдельно для каждого нового типа значений.
 
Добрый день.

Суть проблемы вкратце. Необходимо задать индивидуальную нумерацию для повторяющихся позиций в столбце.

Чуть шире. Есть таблица с столбцом дат и, допустим, видов обуви. Конечная цель удалить строку с самой ранней позицией каждого из видов обуви.

Пораскинув мозгами было решено задать в столбце индивидуальную нумерацию для каждого вида обуви, а потом удалить все строки под номером 1.

Но как это сделать ума ни приложу. Чем больше гуглю тем дальше я от решения проблемы, а по старой традиции все это нужно сделать ещё вчера.

Макросами не владею, последние 10 лет все проблемы решались через ВПР и сводные таблицы.
 
Kerlin, макросы не нужны, считайте количество повторов от текущей ячейки вверх.
Но когда удалите все 1 - то все 2 станут 1. Наверное, если не рухнет... лучше сперва формулы заменить на значения.
 
Для ясности, таблиц несколько, в каждой ~800к строк на ~100+ столбцов. Типов значений которые мне нужно пронумеровать несколько тысяч. Я пытаюсь понять, как задать формулу в соседнем столбце, что бы автоматически задать нумерацию для каждого из этих значений. Ясное дело, что формулу на значение я поменяю... но где эту формулу взять? Экспериментировать и что-то искать особо времени нет, задать какую-то вариацию из ВПР и ЕСЛИ я пробовал, но с ходу ничего дельного не получилось

Опять же как это скормить гуглу, что бы найти что-то полезное, мозг не варит.  
 
Давайте покажем как можно счётесли() применить.
 
Hugo, будьте так добры, если вам не трудно.

Но учтите, я тупой, а мне это нужно будет объяснить другим людям.

ДАТАОБУВЬ
01.01.2024БОТИНКИ1
02.01.2024БОТИНКИ2
03.02.2024БОТИНКИ3
01.01.2024КЕДЫ1
02.01.2024КЕДЫ2
03.01.2024КЕДЫ3
01.01.2024КРОССОВКИ1
02.01.2024КРОССОВКИ2
03.01.2024КРОССОВКИ3
01.01.2024ТУФЛИ1
02.01.2024ТУФЛИ2
03.01.2024ТУФЛИ3
Какую черную магию нужно применить, чтобы нумерация проставлялась автоматически для каждого значения как в 3 столбце.  
 
Цитата
Kerlin написал:
черную магию

ДАТА ОБУВЬ №
01.01.2024 БОТИНКИ 1 1 =СЧЁТЕСЛИ($B$1:B2;B2)
02.01.2024 БОТИНКИ 2 2 =СЧЁТЕСЛИ($B$1:B3;B3)
03.02.2024 БОТИНКИ 3 3 =СЧЁТЕСЛИ($B$1:B4;B4)
01.01.2024 КЕДЫ 1 1 =СЧЁТЕСЛИ($B$1:B5;B5)
02.01.2024 КЕДЫ 2 2 =СЧЁТЕСЛИ($B$1:B6;B6)
03.01.2024 КЕДЫ 3 3 =СЧЁТЕСЛИ($B$1:B7;B7)
01.01.2024 КРОССОВКИ 1 1 =СЧЁТЕСЛИ($B$1:B8;B8)
02.01.2024 КРОССОВКИ 2 2 =СЧЁТЕСЛИ($B$1:B9;B9)
03.01.2024 КРОССОВКИ 3 3 =СЧЁТЕСЛИ($B$1:B10;B10)
01.01.2024 ТУФЛИ 1 1 =СЧЁТЕСЛИ($B$1:B11;B11)
02.01.2024 ТУФЛИ 2 2 =СЧЁТЕСЛИ($B$1:B12;B12)
03.01.2024 ТУФЛИ 3 3 =СЧЁТЕСЛИ($B$1:B13;B13)
Изменено: Hugo - 19.06.2024 20:04:39
 
Вариант с помощью PQ. Создать запрос, все содержимое заменить на код запроса:
pq
В коде запроса Имя1 и Имя2 заменить на имена столбцов, по которым группироваться.

...вариант оказался сильно с условностями )) Собираются все таблицы из Книги, а выгруженный на лист запрос также будет таблицей, поэтому общая последовательность такая: а) набор данных преобразовать в умные таблицы; б) создать запрос, выгрузить его на лист и сразу обновить; в) не создавать новые таблицы после выгруженного на лист запроса. Как итог, если не осознавать почему и для чего пункты а, б, в — в предложенном виде лучше не использовать.
Изменено: sotnikov - 19.06.2024 21:10:05
 
Hugo, sotnikov, Благодарствую, завтра буду пробовать.

Надеюсь оно не сгорит все к чертовой матери. Наши машинки с трудом открывают эти файлы. Про PQ я узнал месяц назад, когда склеивал все эти файлы.  
 
Kerlin, так? вариант через PQ. результат - в таблице РЕЗУЛЬТАТ
коли с PQ только познакомились  -там все по шагам
Изменено: voler83 - 19.06.2024 22:29:13
 

Здравствуйте.

Код
=СЧЁТЕСЛИ($B$1:$B$10000;B2)-СЧЁТЕСЛИ($B$1:B2;B2)

Пропишите эту формулу и протяните вниз. Фильтром выделите ячейки с результатом больше нуля и удалите эти строки. Что останется это последние данные, при условии что таблица отсортирована по датам от ранней к поздней.

Страницы: 1
Наверх