Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Перенести нумерацию столбцов с удаленными строками на новую таблицу
 
Помогите пожалуйста имеется исходная таблица из нее удаляем некоторые позиции вручную, из нее получаем 2 таблицу с удаленными позициями, теперь нужно сделать 3 таблицу но уже с позициями которые удались, вот я и подумал например нумерация столбцов в основной таблице,  в 2 таблице идет не по порядку (за счет удаления позиций), как бы эту нумерацию наложить на 3 таблицу пока идентичной основной чтобы видеть какие номера строк были удалены, буду очень благодарен за помощь, спасибо.
 
где все эти таблицы
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
где все эти таблицы
В экселе, вот первая таблица с основной нумерацией, вторая с удаленными строками, возможно ли нумерацию не по порядку из 2 таблицы наложить на 3 таблицу идентичную 1 основной чтобы нумерация распределилась с учетом удаленных строк
 
Цитата
alimofo написал:
В экселе,
посмотрел у меня нету странно  :( , ждите мож у кого то есть  
Лень двигатель прогресса, доказано!!!
 
файлы прикладываю с примером, большого обьема уменшаю ничего не видно
 
Цитата
Сергей написал:
мож у кого то есть
Сергей, у меня тоже нет. Видимо, придётся MS Office переустанавливать...
 
alimofo, тут не нужны ваши огромные рабочие таблицы сделайте пример трех таблиц (было, стало, хоту такую) в реальной структуре строк на 20
Лень двигатель прогресса, доказано!!!
 
Цитата
alimofo написал:
имеется исходная таблица из нее удаляем некоторые позиции вручную
получаем 2 таблицу с удаленными позициями,
теперь нужно сделать 3 таблицу но уже с позициями которые удались,



Цитата
alimofo написал:
вот я и подумал например нумерация столбцов в основной таблице,  в 2 таблице идет не по порядку (за счет удаления позиций),
как бы эту нумерацию наложить на 3 таблицу пока идентичной основной чтобы видеть какие номера строк были удалены

Думаю, не только я не поняла. Чем отличается 2 таблица от 3-й? Тем что в 3-й вы хотите нумерацию как в 1-й?
8-0  
 
1 таблица там все позиции нумерация до 38, 2 таблица с удаленными позициями нумерация не по порядку до 40, возможно ли в 3 таблице распределить нумерацию как во 2 таблице, а которые позиции были удалены у них нумерация была бы с пропуском
 
Вы в третьей покажите как нужно, а то что-то ничего не понятно.
"Все гениальное просто, а все простое гениально!!!"
 
Так:
=ЕСЛИОШИБКА(ИНДЕКС('Таблица 2'!$A$8:$A$20;ПОИСКПОЗ(C8;'Таблица 2'!$C$8:$C$20;0));"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Nordheim написал:
Вы в третьей покажите как нужно, а то что-то ничего не понятно.
Вот вручную проставил как надо в 3 таблице, пропуски нумерации это позиции удаленные, которых нет во 2 таблице.
 
если Таблица№1 исходник, то почему таблица№3 и Таблиц2№2 отличается наличием строк? 39 и 40 нет в таблице№1? По какому критерию удаляются строки формируя Таблицу№2?
"Все гениальное просто, а все простое гениально!!!"
 
смотрите в файле это надо
Лень двигатель прогресса, доказано!!!
 
Еще есть функция: =ИНДЕКС(А:B; ПОИСКПОЗ(R5; А; 0); 2)

Она ищет в указанном массиве, указанном столбце нужные значения (значения, которые в другой таблице) и притягивает любой столбец (указанный) в таблицу, где соответственно вводиться эта формула (из таблицы, где ищем)

Это а-ля ВПР, но лучше
Страницы: 1
Читают тему (гостей: 1)
Наверх