Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
выборка каждой 5 строки и данных из нее, выборка каждой 5 строки и данных из нее
 
Добрый день, есть база данных в которой заказы разбиваются на 5 строчки (для сводной таблицы). Нужно в свод сделать как то чтобы копировалась первая строчка заказа, а потом след заказ,который идет через 5 строки.... помогите пожалуйста.. Руками муторно...
 
Добрый день.
Контрагент:
Код
=ИНДЕКС('план заказов'!$B$1:$AD$22;СТРОКА('план заказов'!B3)+5*(СТРОКА('план заказов'!B1)-1);1)

Заказ:
Код
=ИНДЕКС('план заказов'!$B$1:$AD$22;СТРОКА('план заказов'!B3)+5*(СТРОКА('план заказов'!B1)-1);2)

Сумма:
Код
=ИНДЕКС('план заказов'!$B$1:$AD$22;СТРОКА('план заказов'!B3)+5*(СТРОКА('план заказов'!B1)-1);6)


З.Ы.
А, да. Потом все три формулы - растянуть вниз.
Изменено: Пытливый - 19 Ноя 2018 19:25:23
Кому решение нужно - тот пример и рисует.
 
См. вариант.
 
Сводная.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
 
=ИНДЕКС('план заказов'!B$3:B$28;ЦЕЛОЕ((СТРОКА(A2))*5)-9)
 
Спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх