Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Неправильное кол-во аргументов в функции =ЕСЛИ(И(
 
Требуется в столбец D начиная с 9 строки подставить/сцепить значение из диапазона A2:A5 в зависимости от соблюдения или НЕсоблюдения условий.
А конкретно: если сумма длин строк A9+B9 > С$2  И при этом она же (сумма длин строк) < C$3 тогда подставить/сцепить с A$3 и т.д.

моя формула
Код
=ЕСЛИ(И(ДЛСТР(A9)+ДЛСТР(B9)>C$2;ДЛСТР(A9)+ДЛСТР(B9)<C$3;СЦЕПИТЬ(A$3))) 
- выдаёт ошибку #Н/Д. Неправильное кол-во аргументов.

Подскажите пожалуйста, что в ней не так.
 
Vadim_Zz, скобки смотрите внимательно функция "И" не закрыта и что будет если ЛОЖЬ не указано
Лень двигатель прогресса, доказано!!!
 
Скобки неправильно расставили
 
bigorq, а в примере можете исправить. Я все вроде перепробовал, нечего не получается.
 
А вот разделять функции  пробелами не пробовали...
=ЕСЛИ(пробелы остаток формулы
Далее смотрите в конец формулы. Функция закрывается скобкой
пробелы)
отделяем условие; то, что при ИСТИНА; то, что при ЛОЖЬ
Дальше отделяем функцию И...
Не знаете синтаксиса - можно в справке посмотреть.

Так найдете ошибку и лучше будете понимать формулу
 
Vadim_Zz, ваш файл открывается с ошибками
ывыф.png (9.81 КБ)
Лень двигатель прогресса, доказано!!!
 
Сергей, благодарю. Получилось  :)  
Страницы: 1
Читают тему (гостей: 1)
Наверх