Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сортировка данных без конкретного значения в ячейке
 
Подскажите, как можно написать функцию ПОИСКПОЗ, если в ячейке не задано конкретное значение, а <  или > искомого. Не получается  установить искомое значение - ячейка
 
Emelion, странно в названии темы о сортировке, а в описании поискпоз и что то совсем непонятно.
Просто опишите что вы пытаетесь сделать не какой формулой не как вы это делаете, а что конкретно нудно например посчитать количество яблок соответствующих выбранным размерам.
Изменено: Mershik - 16 Янв 2020 10:55:30
 
Нужно чтоб при вводе номера и показателя в отдельной ячейке отображался соответствующий им коэффициент
 
Код
=ГПР(B17;B4:E12;ПОИСКПОЗ(B15;A4:A12;0);1)
Внесите в B4:E4 , 5000000, 7000000, 10000000
                   
05000000700000010000000
Изменено: МатросНаЗебре - 16 Янв 2020 11:17:51
 
Цитата
МатросНаЗебре написал:
Внесите в B4:E4 , 5000000, 7000000, 10000000                           05000000700000010000000
тогда появляются дополнительные яейки. А без них как то можно?
 
Emelion, замените их в 6 строке)
или раз вообще не хотите ничего менть в формуле предложенной выше замените часть
Код
=ПОИСКПОЗ(B15;A4:A12;0)

на

Код
=ЕСЛИ($B$17<5000000;1;ЕСЛИ($B$17<=7000000;2;ЕСЛИ($B$17<=10000000;3;4)))
Изменено: Mershik - 16 Янв 2020 11:32:37
 
Код
=ИНДЕКС($M$7:$P$7;ПОИСКПОЗ(J10;{9999:99:39:9};-1))
Код
=ИНДЕКС($M$7:$P$7;5-ПОИСКПОЗ(J10;{0:10:40:100}))

Для первого:

Код
=ИНДЕКС(B8:E12;B15;ПОИСКПОЗ(B17;10^6*{0;5;7;10}))
Изменено: Светлый - 16 Янв 2020 11:42:51
 
Цитата
Светлый написал:
Код ? 1=ИНДЕКС($M$7:$P$7;ПОИСКПОЗ(J10;{9999:99:39:9};-1))
Код ? 1=ИНДЕКС($M$7:$P$7;5-ПОИСКПОЗ(J10;{0:10:40:100}))
Спасибо. Это то что нужно. Я понял - фигурные скобки решают задачу)
Подскажите, как расшифровать вторую формулу?
как понять 5 - ПОИСКПОЗ... - что такое 5
 
Цитата
Emelion написал:
5 - ПОИСКПОЗ
Задаёт обратный порядок значений. Поиск по фигурным скобкам прямой, а значение коэффициентов из ячеек обратное.
Страницы: 1
Читают тему (гостей: 1)
Наверх