Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск на соответствие текста с неполным совпадением
 
Добрый день,
В таблице не получается реализовать запрос на поиск соответствия организаций (столбец F листа "Сводные данные" и столбца D листа "Исх. данные" )  через функцию ВПР по части текста (файл примера прилагаю) -
В столбце D ("номер контракта") имеются записи следующего вида:
ФТ-00-03-2748,   упр.аб
которые в принципе можно привести к 12-ти значным идентификаторам  договоров через функцию (ЛЕВСИМВ(D3;12), но при поиске соответствия необходимо сопоставить данные значения аналогичным показателям из таблицы на листе "Исх.данные", где они имеют уже запись вида
КОНТРАКТ   №ФТ-00-03-2748
к сожалению, через ВПР (вида =ВПР(ЛЕВСИМВ(D3;12);'Исх. данные'!$C$2:$D$7;2;0) )
не получилось найти значения с неполным соответствием (т.е. не получается убрать лишний текст / сравнивать на частичное совпадение)
Прошу подсказать, если возможность решить данную проблему не используя надстройки типа Fuzzy Lookup ?

Спасибо
 
так нужно?
=ВПР("*"&ЛЕВСИМВ(D3;12)&"*";'Исх. данные'!$C$2:$D$7;2;0)
Каждому For свой Next
 
Спасибо! Получилось практически то, что нужно.
Попробую на реальном файле.  
Страницы: 1
Читают тему (гостей: 1)
Наверх