Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммировать значение по двум условиям, одно из которых представлено в виде списка соответствий, без вспомгательного столбца, с использованием только vlookup index match sum, if
 
Пожалуйста помогите решить вопрос из теста

нужно заполнить одну  таблицу из двух таблиц не используя вспомогательный столбец
используя только vlookup  index match sum, if

Пример в файле
 
Orca, а в моем суммеслимн и сумм..не подходит ну ладно
Не бойтесь совершенства. Вам его не достичь.
 
Формула массива:
=СУММПРОИЗВ(МУМНОЖ(--($A$2:$A$29=ТРАНСП(ЕСЛИ($H$2:$H$4=H$9;$G$2:$G$4)));{1:1:1})*(ГОД($B$2:$B$29)=$G10);$C$2:$C$29)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Я бы наверное на СУММПРОИЗВ() строил, но вот как туда два значения ключа воткнуть (вернее не именно два, а неопределённое количество) не придумал...
 
Orca,
Не бойтесь совершенства. Вам его не достичь.
 
вопрос почему Product Category C = KEY
Лень двигатель прогресса, доказано!!!
 
Это просто название категории
 
ещё вариант
Код
=СУММ(ЕСЛИ(ИНДЕКС($H$2:$H$4;ПОИСКПОЗ($A$2:$A$29;$G$2:$G$4;0))=$H$9;$C$2:$C$29;0)*(ГОД($B$2:$B$29)=G10))
 
в вашем примере А = KEY и С =KEY
Лень двигатель прогресса, доказано!!!
 
Сергей, два продукта в одной категории.....в этом то одна из сложностей

Mershik, у меня почему то нули в таблице........
 
[QUOTE]Sticsспасибо за формулу. Браво !!!   Именно то что надо !!
Спасибо !!  :D  :D  :D  
 
Странно работает это "то что надо" - если чуть поиграть фильтрами то итоговая таблица перестаёт правильно считать: http://prntscr.com/t1guo9
Это только мне так не везёт?
Понял - у меня в 2010 формулы пересчитываются неправильно. Почему?
Изменено: Hugo - 17 июн 2020 17:10:03
Страницы: 1
Читают тему (гостей: 1)
Наверх