Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск нескольких максимальных значений
 
Здравствуйте!
Есть ряд, в котором несколько максимальных одинаковых значений. Нужно выделить позиции всех максимальных значений в ряду, однако ПОИСКПОЗ выделяет позицию только одного максимального значения. Как выделить позиции всех максимальных одинаковых значений?
Спасибо.

P.S. Расширю суть задачи - требуется искать все позиции одинаковых значений в ряду (максимальных, минимальных, любых других).
Изменено: vsg-good - 21 июл 2020 13:33:46
 
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($A2:$H2=МАКС($A2:$H2);СТОЛБЕЦ($A:$H));СТОЛБЕЦ(A2));"")
 
Спасибо!
 
vsg-good, почитайте ЗДЕСЬ и ЗДЕСЬ  
 
ещё вариант
Код
=АГРЕГАТ(15;6;СТОЛБЕЦ($A$1:$H$1)/($A$2:$H$2=МАКС($A$2:$H$2));СТОЛБЕЦ(A1))
Страницы: 1
Читают тему (гостей: 1)
Наверх