Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Расчет уникальных просмотров и уникальных посетителей сайта
 
Добрый день.
Прошу помочь с формулами для заполнения столбцов таблицы "Уникальный просмотр" и "Уникальный пользователь". Нужно чтобы столбец "Уникальный просмотр" заполнился показателями 1 или 0, в зависимости от того, происходил ли просмотр одного уникального файла одним уникальным пользователем за текущие сутки, без учёта повторного открытия того же файла тем же пользователем за текущие сутки (если наступил следующий день, то считать этот просмотр по новой), то есть 1, или нет, то есть 0. Столбец "Уникальный пользователь" нужно заполнить показателями 1 или 0, в зависимости от того просматривал ли пользователь любой файл за текущий день (если наступил следующий день, то считать этого пользователя по новой), то есть 1, или нет, то есть 0.
Особенности: Возможен вариант открытия одного и того же файла одним и тем же пользователем в одно и тоже время (в данном случае нужно, чтобы по одной строке "Уникальный просмотр" была 1, а по остальным 0). Возможно открытие нескольких файлов одним и тем же пользователем, в одно и тоже время (в данном случае нужно, чтобы была 1 по этому пользователю за текущие сутки один раз в строке "Уникальный пользователь").
Приложил образец.
 
Код
=--(СЧЁТЕСЛИМН(A$2:A2;A2;C$2:C2;C2;D$2:D2;D2)*СЧЁТЕСЛИМН(A$2:A2;A2;B$2:B2;B2;C$2:C2;C2)=1)
Код
=--(СЧЁТЕСЛИМН(A$2:A2;A2;C$2:C2;C2)=1)


или
Код
=--(СЧЁТЕСЛИМН(A2:A$18;A2;C2:C$18;C2;D2:D$18;D2)*СЧЁТЕСЛИМН(A2:A$18;A2;B2:B$18;B2;C2:C$18;C2)=1)
Код
=--(СЧЁТЕСЛИМН(A2:A$18;A2;C2:C$18;C2)=1)
 
Доброе время суток.
Почему
Файл1 01.01.2020 13:21:22 0 не уникальный просмотр, а
Файл4 01.01.2020 14:00:54 1 уникальный просмотр?
Почему
Пользователь1 Файл7 01.01.2020 13:44:02 1 1 уникален по последнему просмотренному файлу, а
Пользователь3 Файл4 01.01.2020 14:00:54 1 1 по первому просмотренному файлу?
 
цитата - не бездумная копия [МОДЕРАТОР]

Андрей Лящук , спасибо большое.
Но я в итоге пришел к тому, что сначала надо сцепить пользователя, файл, дату, а потом сравнить по формуле =ЕСЛИ(СЧЁТЕСЛИ(E$1:E2;E2)=1;1;0) - по столбцу "Уникальный просмотр", а по "Уникальный пользователь" - сцепить пользователя и дату, а потом сравнить по формуле =ЕСЛИ(СЧЁТЕСЛИ(G$1:G2;G2)=1;1;0)
Страницы: 1
Читают тему (гостей: 1)
Наверх