Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет строк с текстом до пустой строки
 
Здравствуйте, дорогие форумчане, помогите разобраться с формулой.
Есть столбец со строками наполненными разным текстом, который прерывается пустыми строками и тем самым делится на "логические единицы". Нужна формула которая подсчитает количество строк с текстом в "логической единице" и выведет это значение напротив каждой строки в "логической единице".
Спасибо за помощь. Приложил файл с примером результата в желтом столбце.  
Изменено: dom23 - 21 авг 2020 00:39:04
 
Добрый вечер.

Так?
=IF(B3="";0;E2+1)
Изменено: bigorq - 21 авг 2020 00:03:04
 
Код
=ЕСЛИ(ЕПУСТО(B2);"";ЕСЛИ(A2="Сайт";МИН(ЕСЛИ(ЕПУСТО(B2:$B$91);СТРОКА(B2:$B$91)-СТРОКА();""));E1))
Каждому For свой Next
 
bigorq,Спасибо, немного не то, я оплошал с описание формулы. Нужно что бы выводилось общее кол-во строк в "логической единице" на против каждой строки.  
 
Цитата
dom23 написал:
привязана к слову сайт
какой пример, такой и ответ...
Код
=ЕСЛИ(ЕПУСТО(B2);"";ЕСЛИ(ЕТЕКСТ(A2);МИН(ЕСЛИ(ЕПУСТО(B2:$B$91);СТРОКА(B2:$B$91)-СТРОКА();""));E1))
Каждому For свой Next
 
buchlotnik, спасибо огромное Вы очень помогли!  :D  
Страницы: 1
Читают тему (гостей: 1)
Наверх