Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
автозаполнение ячеек след столбца, автозаполнение ячеек след столбца
 
Добрый день! Подскажите как сделать автоматическое заполнение ячейки справа. Слева наименования субъектов РФ и чтобы при их добавлении в столбце справа по этой же строке автоматом заполнялось наименование федерального округа к которому относится субъект. Пример во вложении
Изменено: Владислав Меркулов - 3 окт 2020 19:24:26
 
Может проще так? )
 
проще. но хочет автоматизировать процессы. это просто как пример
 
В модуль Лист2
Код
Private Sub Worksheet_Change(ByVal Target As Range)
 If Not Intersect(Target, Range("A1:A1000")) Is Nothing Then
    Application.EnableEvents = False
Dim Oblast As Range
Dim i As Integer
    With Worksheets("Лист1")
      Set Oblast = .Columns(1).Find(Target, , xlValues, xlWhole)
        If Not Oblast Is Nothing Then
            i = Oblast.Row
          Do
            i = i - 1
          Loop While .Cells(i, "A").Interior.ColorIndex = -4142
        End If
        Target.Offset(, 1) = .Cells(i, "A")
    End With
 End If
    Application.EnableEvents = True
End Sub
 
спасибо. но в макросах я вообще не силен. возможны еще варианты?
 
Вот ещё вариант (аналог как у Kuzmich, только через массив)
Изменено: New - 3 окт 2020 21:07:37
 
а без макросов не обойтись? я  в них не силен...
 
Владислав Меркулов, можно, но формулу нужно будет протягивать
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК("Ф.О.";Лист1!$A$1:ИНДЕКС(Лист1!$A$1:$A$93;ПОИСКПОЗ(A1;Лист1!$A$1:$A$93;0);1));Лист1!$A$1:$A$93);"")
Изменено: Mershik - 3 окт 2020 21:24:59
Не бойтесь совершенства. Вам его не достичь.
Страницы: 1
Читают тему (гостей: 1)
Наверх