Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумма значений за указанный период в случае если годы в строках, а месяцы в столбцах
 
Добрый день! Можно ли создать формулу (желательно без формул массива и использования ctrl+shift+enter), которая в моем примере позволит считать сумму по нужной стране за заданный период. Период задается месяцем и годом начала и месяцем и годом конца.
Т.е. нужно, чтобы красное значение (сумма) изменялось после изменения синих параметров.
Excel 2016, Windows 10
Screenshot_1.png (43.98 КБ)
Изменено: Roomon - 26 дек 2020 12:39:31
 
=СУММПРОИЗВ((B3:B23=R8)*(C3:C23>=R5)*(C3:C23<=T5)*D3:O23)-СУММПРОИЗВ((B3:B23=R8)*(C3:C23=R5)*(D2:O2>=1)*(D2:O2<Q5)*D3:O23)-СУММПРОИЗВ((B3:B23=R8)*(C3:C23=T5)*(D2:O2>S5)*(D2:O2<=12)*D3:O23)
 
Код
=СУММ((ДАТА(C3:C23;D2:O2;1)>=ДАТА(R5;Q5;1))*(ДАТА(C3:C23;D2:O2;1)<=ДАТА(T5;S5;1))*(B3:B23=R8)*D3:O23)
Код
=LET(x;ДАТА(C3:C23;D2:O2;1);СУММ((x>=ДАТА(R5;Q5;1))*(x<=ДАТА(T5;S5;1))*(B3:B23=R8)*D3:O23))

или
Код
=СУММ((C3:C23+D2:O2%>=R5+Q5%)*(C3:C23+D2:O2%<=T5+S5%)*(B3:B23=R8)*D3:O23)
Код
=LET(x;C3:C23+D2:O2%;СУММ((x>=R5+Q5%)*(x<=T5+S5%)*(B3:B23=R8)*D3:O23))
Изменено: buchlotnik - 26 дек 2020 15:54:22
Каждому For свой Next
 
Михаил Витальевич С., buchlotnik, спасибо! То, что нужно!
Страницы: 1
Читают тему (гостей: 1)
Наверх