Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Извлечь данные из одной таблицы из множества по номеру этой таблицы
 
Здраствуйтеуважаемые форумчане.
Помогите плиз, нужна помощь.

Задача:
Если номер совпадает с номером таблицы данных
в конечную таблицу берем данные из нужной таблицы

Загвоздка в том что "Таблиц данных" много, больше 200,
поэтому использовать простое ЕСЛИ не можем т.к. максимум ЕСЛИ можно 64шт.

Есть простое решение задачи, стандартными функциями excel 2010, 2016?
Функции ЕСЛИМН и других продвинутых функций у меня в Екселе нет!

https://files.dp.ua/ru/BZyxTfm3 - файл примера

Буду очень благодарен за помощь уважаемых форумчан.

 
 
Макрос на изменение ячейки с номером,
ищем номер в столбце № табл и переносим соответствующие данные в конечную таблицу
 
А можете отписать макрос, я не очень в этом разбираюсь..((
Но всеже лучше если возможно формулой а не макросом.

Спасибо что откликнулись.
 
yuraok,
Вы прикрепите пример на форуме, чтобы не ходить по ссылкам
 
используйте ИНДЕКС
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
пример
 
В модуль листа1
Код
Private Sub Worksheet_Change(ByVal Target As Range)
  If Not Intersect(Target, Range("B3")) Is Nothing Then
    Application.EnableEvents = False
Dim FoundNomer As Range
  Set FoundNomer = Columns("H").Find(Target, , xlValues, xlWhole)
    FoundNomer.Offset(, 1).Resize(4, 3).Copy Range("D3")
  End If
    Application.EnableEvents = True
End Sub

Макрос срабатывает на изменение значения в ячейке В3
 
Можно формулой, но боюсь на больших объемах будет тормозить.
 

не могу запустить..( ошибка при сохранении макроса
Не сохраняется даже сам документ ексель с той же ошибкой..
 
=INDEX(I:I;MATCH($B$3;$H:$H;)+ROWS(D3:D$3)-1) или я что-то не правильно понял?
а если вынести в отдельную ячейку MATCH($B$3;$H:$H;) то будет шустрее.
Изменено: БМВ - 23 фев 2021 15:18:12
По вопросам из тем форума, личку не читаю.
 
Посмотрите в файле
 
БМВ, супер!!! Вы все правильно поняли, БОЛЬШОЕ СПАСИБО!!
Здоровья Вам и всех благ!!!)
Код
=ИНДЕКС(K:K;ПОИСКПОЗ($B$3;$H:$H;)+ЧСТРОК(F$3:F5)-1)

Это то что нужно.

Всем еще раз большое спасибо что отозвались!
 
БМВ, Додуматься до простых решений иногда бывает труднее всего).
Страницы: 1
Читают тему (гостей: 1)
Наверх