Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Перемножить диапазоны столбцов с условиями
 
Здравствуйте, нужна помощь, уже сломал всю голову с этими диапазонами...
в столбцах "Продукция" подобрал формулу вычисления суммы
Код
=ЕСЛИ($B8="";"";ЕСЛИ($B8="РД";"";ЕСЛИ($B8="ФЛ";"";ЕСЛИ($B8="ДП";ПРОИЗВЕД(ВПР($D8;данные!$T$12:$AB$43;9;0);$E8)))))

тут проще, можно протянуть по каждому дню её, единственное не удобно когда добавляешь строки в какие-либо дни, каждый раз приходится протягивать формулу
если можно её ещё упростить, то буду благодарен вашим советам.

вопрос и суть темы далее..
в ячейку С44 необходимо вычислить количество затраченного "цемента" за весь месяц, если организация "ДП", объёма столбец Е и рецепта по каждому дню столбец D
как посчитать по диапазону?
Код
=ЕСЛИ($B5="";"";ЕСЛИ($B5="РД";"";ЕСЛИ($B5="ФЛ";"";ЕСЛИ($B5="ДП";ПРОИЗВЕД(ВПР($D5;данные!$T$12:$Y$43;2;0);$E5)

      В5:В35                    В5:В35                 В5:В35                      В5:В35                            D5:D35=данные!Т12:43?                 Е5:Е35
и если диапазон будет сдвигаться при добавлении строк
в С44 прописал все дни, это объёмно, но работает..  но если добавлять строки то в сумме не будет этих добавленных строк(((
ужас.. прошу помощи профи
 
с промежуточным расчетом
Лень двигатель прогресса, доказано!!!
 
массивная
=SUM(IF(B5:B35="ДП";E5:E35*INDEX(Таблица1[Цемент];N(INDEX(MATCH(D5:D35;Таблица1[Бетон];);)))))
Изменено: БМВ - 04.05.2021 09:15:21
По вопросам из тем форума, личку не читаю.
 
Сергей, спасибо за вариант, массивом ниже чуть поудобнее подсказали
 
БМВ, спасибо огромное) выручили капец как..
ещё вопросик
Таблица1[Цемент] и Таблица1[Бетон]  мне в других ячейках так и вбивать? понятно что поменять цемент на щебень или песок, а название "таблица" само найдётся или мне эту таблицу как то надо завиксировать этим названием?
объясните пожалуйста лузеру
 
Да можно не заморачиваться, а просто выбирать диапазон обычный. Справочник фиксированный, по этому прелести  умной таблицы не нужны.
ну или по аналогии с тем что выше использовать имена столбцов.
По вопросам из тем форума, личку не читаю.
 
БМВ, большое спасибище, попробовал перенёс, крутяк всё пашет) увидел что при замене названия таблицы выбор появляется. Класс, я голову ломал 4 суток, и ночью и днём искал в инете, вычитывал может хоть чтобы примерно подобное найти, и всё в пустую))
классный форум, тут тоже искал читал, много толкового
респектище!
Страницы: 1
Читают тему (гостей: 1)
Наверх