Страницы: 1
RSS
Подсчёт одинаковых значений за определённый период
 
Приветствую!


В файле есть 2 столбца:
1) Отображаются названия абонементов, которые покупают
2) Дата и время покупки
Определенный абонемент "НОЧЬ" нужно считать за период с 8 утра до 8 утра и относить эти данные к первому дню в данном интервале.
Все остальные абонементы, считаются просто за конкретную дату.

Приложил пример, более подробно всё расписал в EXEL.

P.S. У нас есть CRM система и она позволяет выгружать всевозможные отчёты в виде EXEL, покупка абонементов, загрузка конкретных компьютеров в разное время, активность пользователей по дням и т.д. Нужна помощь, для того, чтобы создать шаблоны для обработки этих всех данных по определенным критериям, чтобы мы могли строить инфографику. Естественно за оплату, если есть такой специалист - Welcome!
Прошу прощения, если написал не туда.
 
Владимир, Вариант
Код
=СУММПРОИЗВ((ЕОШ(ПОИСК(F$14;$A$2:$A$40))=ЛОЖЬ)*(ДАТА(ГОД($B$2:$B$40);МЕСЯЦ($B$2:$B$40);ДЕНЬ($B$2:$B$40))=$E15))
Только будет работать если приведете данные к 1му виду, если у вас в данных "Пакет 4,5 часа" пишется 4,5 через "," (Запятую) то и в шапке таблицы для подсчёта нужно писать так же через запятую.  
 
Цитата
Александр П. написал:
для подсчёта нужно писать так же через запятую
Массивная
Код
=СЧЁТ(ЕСЛИ((ЕЧИСЛО(ПОИСК(F$14;$A$1:$A$40)))*($B$1:$B$40>=$E15+1/3)*($B$1:$B$40<1+$E15+1/3);$B$1:$B$40))
 
Александр П., я вижу формула одинаковая на все пакеты, подскажите пожалуйста. Как для пакета НОЧЬ считать за период 10.05 08:00 по 11.05 08:00 , и результаты записать в 10.05 ? У меня большой набор данных просто и очень часто, ночной абонемент, могут купить после 00:00, а это всё относится к вечерней смене администратора.
Изменено: vikttur - 11.06.2021 12:30:22
Страницы: 1
Читают тему (гостей: 1)
Наверх