Страницы: 1
RSS
Ссылка на несмежные ячейки в константе массива для поиска совпадений
 
Здравствуйте.
Перерыл Интернет и не нашёл

Не пойму как поставить корректные ссылки на ячейки с искомыми параметрами, расположенными хаотично для поиска значений в диапазоне.

Возможные формулы поиска
Формула массива
Код
=ЕСЛИ(СЧЁТ(ПОИСК({ссылка на ячейку1;ссылка на ячейку2;ссылка на ячейку3};A3:A5));1;0)

или обычная формула
Код
=ЕСЛИ(СЧЁТ(ИНДЕКС(ПОИСК({ссылка на ячейку1;ссылка на ячейку2;ссылка на ячейку3};A3:A5);;));1;0)

Мне вообще интересно наконец-то узнать как можно сгруппировать ссылки на несмежные ячейки в массив, воспринимаемый формулой. Я узнал, что такое константа массива, но, как я понимаю, это невозможно использовать для создания массива по адресам ячеек.
 
Код
=СЧЁТЕСЛИМН($B$5:$F$15;H$3)
 
ОК, поправочка, там есть и другие значения, которые не нужно использовать.
Обновил файл.
Изменено: Max.Liubimov - 13.10.2021 19:25:22
 
Формула  не помогла?
 
Нет. Формула не может помочь, потому что там есть множество других данных, в т.ч. и даты, которые нельзя учитывать. Я так понимаю, что в Excel нет аналога построения массива в фигурных скобках из ссылок, как в Google.
Страницы: 1
Читают тему (гостей: 1)
Наверх