Страницы: 1
RSS
Проверка варианта ответа на соответствие (Excel 2016)
 
Коллеги, если можете помогите пожалуйста.
Задача вроде бы простая но с формулами не могу разобраться, работаю в Excel 2016.

В ячейке"В2" должно выполнятся условие, ЕСЛИ "А2" > 0 и "D2" > 0, тогда "В2" = "А2", но ЕСЛИ "А2" = 0, а "D2" > 0, тогда  "В2" = "D2"
С первой частью разобрался, но второе условие не могу понять как заставить выполняться.
 
в В2
Код
=ЕСЛИ(И(A2>0;D2>0);A2;ЕСЛИ(И(A2=0;D2>0);D2;""))
 
mechanix 85, большое спасибо!
Это то, что нужно, круто!  :idea:  :)  8)
Как говорит Николай Павлов "Когда знаешь, всё просто!"
Еще раз спасибо!
 
office.taes, когда сложно все слепить в одну формулу, то делите ее на составляющие и потом соединяйте
 
mechanix 85, Спасибо за совет! Я это увидел только сейчас, действительно, как вариант можно так делать, но  я и не думал, что так можно. Отличный подход.
 
=ЕСЛИ(D2;ЕСЛИ(A2;A2;D2);"")
 
=ЕСЛИ(D2>0;IF(A2>0;A2;ЕСЛИ(A2=0;D2;""));"")

vikttur, Вить D2, a2 отрицательное пропустил. Но если его не может быть при бальной системе, то
Изменено: БМВ - 22.10.2021 17:50:06
По вопросам из тем форума, личку не читаю.
Страницы: 1
Читают тему (гостей: 1)
Наверх