Страницы: 1
RSS
Поиск наименьшего числа с последующими вычислениями, Поиск наименьшего числа с последующими вычислениями
 
Добрый день!

Подскажите, пожалуйста, с вычислениями.

Выбираем под потребность наименьшую цену(три варианта поставщиков) из столбцов G, H, I. Данным столбцам соответствует кол-во имеющееся у данных поставщиков (D, E, F). Если Первый поставщик по наименьшей цене не закрывает потребность, то ищется вторая наименьшая цена, если потребность не закрыта, то ищется третья наименьшая цена.

Порядок поставщиков должен быть сохранен.

В итоговой таблице должны добавиться 6 столбцов, где и происходят вычисления. Файл приложен.
 
Код
T7:V22        =AA7+AD7+AG7
AA7:AC22      =(G7=ЕСЛИОШИБКА(НАИМЕНЬШИЙ($G7:$I7;1);0))*МИН($C7;--D7)
AD7:AF22      =(G7=ЕСЛИОШИБКА(НАИМЕНЬШИЙ($G7:$I7;2);0))*МИН($C7-СУММ($AA7:$AC7);--D7)
AG7:AI22      =(G7=ЕСЛИОШИБКА(НАИМЕНЬШИЙ($G7:$I7;3);0))*МИН($C7-СУММ($AA7:$AF7);--D7)
 
МатросНаЗебре, благодарю!
Страницы: 1
Читают тему (гостей: 1)
Наверх