Страницы: 1
RSS
Учет времени в отпуске
 
Здравствуйте. помогите с проблемой, есть табель в который я забиваю данные о работе
но нужно посчитать количество рабочих дней, когда работник находился в отпуске и умножить на 8 (эти строки отмечены ОТ)

как это можно реализовать, а то сломал всю голову.
 
Код
=СЧЁТЕСЛИ(E12:AL12;"ОТ")*8
Вполне такой нормальный кинжальчик. Процентов на 100
 
От считает все дни, а нужно только рабочие в данной строке должно быть 9*8=72
 
Код
=СУММПРОИЗВ((ДЕНЬНЕД(день2;2)<6)*(W12:AL12="ОТ"))*8
 
Код
=(СУММПРОИЗВ((ДЕНЬНЕД(день1;2)<6)*(E12:S12="от"))+СУММПРОИЗВ((ДЕНЬНЕД(день2;2)<6)*(W12:AL12="от")))*8
 
Для коллекции

=СУММПРОИЗВ(($E12:$AL12="ОТ")*(ЕСЛИОШИБКА(ДЕНЬНЕД($E$10:$AL$10;2);0)<6))*8

=COUNTIFS(E12:AL12;"ОТ";IFERROR(WEEKDAY($E$10:$AL$10;2);"");"<6")*8, но эта не уверен, что в excel будет работать
 
Цитата
написал:
Для коллекции

=СУММПРОИЗВ(($E12:$AL12="ОТ")*(ЕСЛИОШИБКА(ДЕНЬНЕД($E$10:$AL$10;2);0)<6))*8

=COUNTIFS(E12:AL12;"ОТ";IFERROR(WEEKDAY($E$10:$AL$10;2);"");"<6")*8 , но эта не уверен, что в excel будет работать


Если брать диапазон с W12:AL12, то всего 11 календарных дней отпуска, из которых 2 приходятся на субботу и воскресенье, их учитывать ненужно, поэтому должно быть 9 рабочих дней * 8 часов = 72 часа
Изменено: Вячеслав - 21.06.2022 13:41:31
 
Цитата
написал:
Код
    [URL=#]?[/URL]       1      =(СУММПРОИЗВ((ДЕНЬНЕД(день1;2)<6)*(E12:S12=  "от"  ))+СУММПРОИЗВ((ДЕНЬНЕД(день2;2)<6)*(W12:AL12=  "от"  )))*8   
 
тут вы водит значение "истина"
 
Цитата
написал:
Код
    [URL=#]?[/URL]       1      =СУММПРОИЗВ((ДЕНЬНЕД(день2;2)<6)*(W12:AL12=  "ОТ"  ))*8   
 
Большое спасибо помогло, сделать чтобы в праздничные не считало ?
 
Цитата
Вячеслав написал:
должно быть 9 рабочих дней * 8 часов = 72 часа
а у Вас сколько получается? Обе в LO 72 часа и вернули.
Попробовал в excel первую нужно вводить как массивную, тремя кнопками Ctrl+Shift+Enter, тогда она возвращает 72 часа, вторая как и ожидалось не работает :(
Изменено: bigorq - 21.06.2022 14:01:23
 
Цитата
написал:
Цитата
Вячеслав написал:
должно быть 9 рабочих дней * 8 часов = 72 часа
а у Вас сколько получается? Обе в LO 72 часа и вернули.
Попробовал в excel первую нужно вводить как массивную, тремя кнопками Ctrl+Shift+Enter, тогда она возвращает 72 часа, вторая как и ожидалось не работает
Понял, свою ошибку. спасибо
Страницы: 1
Читают тему (гостей: 1)
Наверх