Страницы: 1
RSS
Формула для определения кол-ва одной формулой, если в ячейке несколько значений, Формула для определения кол-ва одной формулой, если в ячейке несколько значений
 
Добрый день!
Подскажите пожалуйста, как с помощью одной формулы из нескольких значений  водной ячейке вытащить то, которое имеется в соседней таблице?
ПартияКол-во
яблоко
    груша
    мандарин
помидор
    огурец
НаименованиеКол-во
помело100
грейпфрут400
груша300
петрушка500
огурец800
 
Файл-пример в студию. Как есть - Как надо
Согласие есть продукт при полном непротивлении сторон.

Контакты, благодарности
 
Добавила
 
Формула массива:
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК(D$2:D$6;A2));E$2:E$6))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Еще вариант.
=SUMPRODUCT(SUMIF($D$2:$D$6;TRIM(MID(SUBSTITUTE(A2;CHAR(10);REPT(" ";99));ROW($1:$15)*99-98;99));$E$2:$E$6))
 
Цитата
написал:
=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК(D$2:D$6;A2));E$2:E$6))
Спасибо! А если вместо цифр, будут стоять значения? (Например, вместо 300 слово "штуки", а вместо 800 слово "коробки", есть для такого случая формула?)
 
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(A3;"*"&$D$2:$D$6&"*")*$E$2:$E$6)

Цитата
YuliaKA написал:
А если вместо цифр
массив
Код
=ОБЪЕДИНИТЬ("; ";1;ЕСЛИ(СЧЁТЕСЛИ(A2;"*"&$D$2:$D$6&"*");$E$2:$E$6;""))
Изменено: R091n - 13.02.2024 14:48:51
 
Цитата
YuliaKA написал:
есть для такого случая формула?
Есть
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
написал:
=ОБЪЕДИНИТЬ("; ";1;ЕСЛИ(СЧЁТЕСЛИ(A2;"*"&$D$2:$D$6&"*");$E$2:$E$6;""))
Спасибо!!!
Страницы: 1
Наверх