Страницы: 1
RSS
проверка, что строка входит в массив строк с именем, как сделать проверку, что строка входит в массив строк с именем
 
Всем доброго дня.

У погуглил по форуму но не смог найти. У меня задача сравнить строку с массивом строк. Строки с которыми я сравниваю объединены как массив с именем. и задача просто определить есть ли в данном массиве строк такая строка. Как я понимаю в excel под такое безобразие есть какая то встроенная функция. Хотя я могу ошибаться. Не подскажете как решить задачу? Или где искать вариант решения.
Изменено: alex_j - 13.02.2024 17:37:13 (загрузка файла)
 
Файл-пример приложите. Как есть - Как надо
Цитата
Как я понимаю в excel под такое безобразие есть какая то встроенная функция
VBA Excel. Метод Application.Intersect (пересечение диапазонов)
Согласие есть продукт при полном непротивлении сторон.

Контакты, благодарности
 
Sanja, подгрузил файл. Мне фактически нужно только получить признак. К сожалению как было показать не могу :(
 
alex_j, =COUNTIF(mass.$A$1:$A$28;A2)
 
=СЧЁТЕСЛИ(имяреки;A2)
Согласие есть продукт при полном непротивлении сторон.

Контакты, благодарности
 
Sanja, не тот случай  :)
bigorq, проще: =СЧЁТЕСЛИ(имяреки;A2)

UPD: не успел  :D
Изменено: Jack Famous - 13.02.2024 17:51:10
Во всех делах очень полезно периодически ставить знак вопроса к тому, что вы с давних пор считали не требующим доказательств (Бертран Рассел) ►Благодарности сюда◄
 
Ссылка была приложена ДО файла
Согласие есть продукт при полном непротивлении сторон.

Контакты, благодарности
Страницы: 1
Наверх