Страницы: 1
RSS
Поиск совпадений и заполнение таблицы по условию
 
Всем привет.

Почему-то не работает функция ВПР.

Есть 4 таблицы в которых содержатся кадастровые номера и адреса, которые им соответствуют.
Каждая таблица на отдельном листе по годам: 2020, 2021, 2022, 2023.

Нужно брать кадастровые номера из листа "2020"(из ячейки B) искать их в других трех листах(в ячейках B) записывая результат поиска в ячейку D на искомых листах:
Если уже есть такой номер, то в столбце D написать цифру 1.
Если нет еще такого кадастрового номера, то добавить всю строку в конец списка и присвоить ему цифру 2 также в столбце D.
Если кадастровый номер есть в листе 2021, 2022, 2023, но его нет в листе 2020, то написать в столбце D - 0.

Я пока начал с поиска совпадений кадастровых номеров, но почему-то ошибка.
Остальное ума не приложу как формулами сделать.

Может кто-то сталкивался с подобной задачей?

В макросах не силен к сожалению.

Заранее благодарю!

Вот нарисовал формулу сравнения для листа 2021:
=ЕСЛИ(СЧЁТЕСЛИ('2020'!$B$2:$B$17;'2021'!$B$2:$B$6)>0;"Нашлось";"Не нашлось")
Изменено: Роман Русинов - 30.03.2024 14:43:11 (Доработка формулы)
 
Цитата
Роман Русинов написал:
Почему-то не работает функция ВПР.
=ВПР('2020'!B2;$B$2:$B$7;2;ЛОЖЬ)
Привет. Справку почитайте про ВПР.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
написал:
=ВПР('2020'!B2;$B$2:$B$7;2;ЛОЖЬ)
Извиняюсь, а что тут не так?
Я указал диапазон поиска и чтобы он не менялся.
 
В Вашей таблице(судя по формуле), 1 столбец, а Вы хотите найти данные во 2-м. Ничего не смущает?
Согласие есть продукт при полном непротивлении сторон
 
Цитата
Роман Русинов:   =ВПР('2020'!B2;$B$2:$B$7;2;ЛОЖЬ)
что тут не так?
функция не вернет того чего нет (задан 1 столбец в искомой таблице)
Вы бы лучше показали какой результат нужен (подозреваю, что пополняемый с каждым листом список уникальных кадастровых номеров)
 
Цитата
написал:
функция не вернет того чего нет (задан 1 столбец в искомой таблице)Вы бы лучше показали какой результат нужен (подозреваю, что пополняемый с каждым листом список уникальных кадастровых номеров)
Понял принцип работы ВПР)
Прилагаю как должно быть в итоге.
 
А как можно сделать так, чтобы если ВПР не нашла значение в искомой таблице, то вся эта строка с этим значением добавилась бы в таблицу и пометилась цифрой 2 в ячейке D, а если строка нашлась, то просто пометила ее цифрой 1 так же в столбце D?
 
День добрый
Считаю, что там где исходные данные - не место формулам и наоборот
Вывел результат рядом - при желании можно скопировать и сохранить как значения
 
Огромное спасибо!
Я бы ни за что не догадался)
 
Эм, когда я удаляю формулу из столбца F, то почему-то эксель падает. У меня 2007.
И когда пытаюсь добавить данные в столбцы с A по С, а потом обращаюсь к формулам, то тоже падает.
Из-за чего это может быть?

В 2010 норм работает...
Изменено: Роман Русинов - 01.04.2024 10:10:51 (Проверка на другой версии офиса)
 
Роман Русинов, пожалуйста
Цитата
почему-то эксель падает. У меня 2007
В 2010 норм работает...
Может там скользко? ) У меня вроде ходит
Т.е. не видя что вы делали - можно только предполагать... возможно что то некорректно перенесли или не учли. И какой объём данных обрабатывается
 
У меня 16 тыс строк. Excel 2010 очень долго их обрабатывает. Это норм?)
Нельзя как-то оптимизировать чтобы Excel не зависал во время обработки формул?

Запускал обработку на сервере с CPU: Xeon Gold 6326, офис 2024. И тоже крайне долго обрабатывается.
Изменено: Роман Русинов - 01.04.2024 15:31:21 (Запуск на сервере)
 
Цитата
У меня 16 тыс строк. Excel 2010 очень долго их обрабатывает. Это норм?)
странно...   )
полста тыщ только массивных формул...  Конечно призадумается
Оптимизировал, добавил доп. столбцов (чтоб не массивничать) пробуйте, но на больших объёмах лучше макрос
 
Все работает. Спасибо!
Изменено: Роман Русинов - 02.04.2024 07:38:18
Страницы: 1
Наверх