Страницы: 1
RSS
Подтянуть на лист данные по нескольким условиям
 
Добрый день.
Есть сотрудник, ему присвоен код, есть подразделения, им тоже присвоены коды. Сотрудник получает ЗП в нескольких подразделениях.
На лист "Лист для загрузки" нужно подтянуть данные с листа ЗП по нескольким условиям: код сотрудника и код подразделения.
Попыталась использовать формулу Суммеслимн, не работает.

Помогите, пожалуйста. Пример во вложении.
 
Shiola, в C2 и протянуть вниз =SUMPRODUCT((ЗП.$D$3:$T$3=B2)*(ЗП.$B$5:$B$6=A3)*(ЗП.$D$5:$T$6))
 
Цитата
написал:
C2 и протянуть вниз =SUMPRODUCT((ЗП.$D$3:$T$3=B2)*(ЗП.$B$5:$B$6=A3)*(ЗП.$D$5:$T$6))
Что-то ругается Эксель..Скрин во вложении
 
Код
=ИНДЕКС(ЗП!$D$5:$T$6;ПОИСКПОЗ(A2;ЗП!$B$5:$B$6;0);ПОИСКПОЗ(B2;ЗП!$D$3:$T$3;0)) 

в предыдущей так поправьте A2 и ! после имени листа

Код
=СУММПРОИЗВ((ЗП!$D$3:$T$3=B2)*(ЗП!$B$5:$B$6=A2)*(ЗП!$D$5:$T$6))
Изменено: Тимофеев - 02.04.2024 17:17:45
 
Спасибо огромное! Все работает!
 
чуть поджать
=ВПР(A2;ЗП!B$5:T$6;ПОИСКПОЗ(B2;ЗП!B$3:T$3;); )
или
=ГПР(B2;ЗП!D$3:T$6;ПОИСКПОЗ(A2;ЗП!B$3:B$6;); )
Страницы: 1
Наверх