Страницы: 1
RSS
Автоматический перенос "+" из-за ячейки "хорошо" в "плохо" и наоборот
 
Добрый вечер! У меня есть таблица1, где имеются следующие столбцы: 1) Номер. 2)имя т/с. 3) исправный. 4) неисправныйПо строчкам идёт перечисление т/с. Указываются нужные ячейки в таблице1 как "+".
Под таблицей есть таблица2 со столбиком "ремонт" где указывается номер машины из таблица1, а так же прописывается информация что с машиной происходит.
Мне нужно, чтобы при указании в таблица1 имя т/с, в таблица1 "+" переходил из ячейки со своим номером в столбике "исправный" в ячейку в столбике "неисправный".
Есть ли способ решить эту задачу?  
Изменено: Korudo - 16.05.2024 15:34:09
 
Цитата
Korudo написал:
У меня есть таблица1
Жалко, что ни у кого нет такой таблицы.
 
Код
=СИМВОЛ(32+(43-32)*(ЗНАК(СЧЁТЕСЛИМН(Таблица2[Ремонт];[@Номер]))=(--(Таблица1[[#Заголовки];[исправный]]="неисправный"))))
 
Цитата
Korudo написал:
Есть ли способ решить эту задачу?
Если правильно понял то:
Таблица 1
в C3
=ЕСЛИ(СЧЁТЕСЛИ($A$10:$A$20;A3)=1;"+";"")
и протянуть вниз
в D3
=ЕСЛИ(C3="+";"";"+")
и протянуть вниз
Таблица 2
в B10
=ЕСЛИОШИБКА(ВПР($A10;$A$3:$D$6;СТОЛБЕЦ(B$2););"")
и протянуть вниз
Без вашего файла только так.
Страницы: 1
Наверх