Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Неправильная работа функции СУММЕСЛИ
 
Вопрос по не корректной работе функции СУММЕСЛИ, я уже не придумаю в чем искать причину. Возможно кто то сталкивался с подобной проблемой, а именно: функция выдает не правильную сумму в связи с тем, что в число суммируемых чисел попадает число равно критерию отбора.
Более подробно: необходимо выбрать из массива данных затраты по 651 счету, в массиве есть затраты в сумме 651,00 но совершенно по другому счету. Путем удаления всех затрат по 651 счету вычислил данный факт.
Одно уточнение, суммы затрат которые суммирует функция являются не числами, а результатами вычислений. Диапазон суммирования - последний столбец диапазона просмотра.
Строил аналогичную таблицу (правда меньших размеров) на другом листе - все работает нормально, а тут как заколдованный.
 
И где этот неработающий вариант?
 
Вы бы хоть приложили то, как функцию применяете. Есть предположение, что Вы не в курсе, что функция отбирает только по одному критерию.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
ну если мне нужно выбрать затрат по 651 счету то зачем же мне более одного критерия отбора? формула выглядит следующим образом: =СУММЕСЛИ($D$3:H$296;$D680;H$3:H$296), критерий находится в столбце D, суммы в столбце H.
сам файл довольно велик, что бы выложить, выкладываю фрагмент, отличие лишь в том, что ячейка Н 680 в высылаемом примере считает корректно (значение 0), а в моем файле она выдает значение 651
могу выслать принскрин, если это чем то поможет
Изменено: alisonnik - 7 Май 2013 13:38:32
 
=СУММЕСЛИ($D$3:H$296;$D680;H$3:H$296)
выделенное красным - неверная запись. Диапазон критериев - один столбец, а не несколько. в данном случае работает, но проверяет только по столбцу D3 :D 296
Диапазон суммирования - тоже один столбец.
Ваш пример ничего не дает, т.к. он суммирует пустые ячейки.
Изменено: Михаил С. - 7 Май 2013 14:14:53
 
не совсем Вас понял, синтаксис функции согласно хелпам екселя выглядит: =СУММЕСЛИ(диапазон;критерий;диапазон суммирования), соответственно: $D$3:H$296 - диапазон; $D680 - критерий; H$3:H$296 - диапазон суммирования. критерий находится в одном столбце, а не в нескольких, суммы тоже, диапазон просмотра захватывает и критерии и суммы?!
пример мною выложенный действительно суммирует пустые ячейки и как я писал ранее формула в этом примере работает правильно - сумма нулевых значений - 0. собственно пустыми они стали после того как я методично удалял в них значения, что бы найти причину. действовал так сказать методом исключения.
беда в том, что в рабочем файле та же формула с теми же диапазонами с нулевыми значениями по критерию отбора 651 выдает значение "651".
иными словами в диапазон суммирования попадает число которое там не находиться! случайно или нет но это число совпадает с критерием отбора!
Изменено: alisonnik - 8 Май 2013 11:04:57
 
Для корректной работы этой функции диапазоны должны быть либо столбцами (с одинаковым количеством строк) либо строками (с одинаковым количеством столбцов)  ;)
 
Цитата
LVL пишет:  либо столбцами... либо строками...
ну почему же?  :D
фрилансер Excel, VBA - контакты в профиле
"Совершенствоваться не обязательно. Выживание — дело добровольное." Э.Деминг
 
А я наивно полагал, что об этой функции все знаю  :D  :D  :D
 
Еще так сработает в примере от ikki:
Код
=СУММЕСЛИ(A2:C10;"а";B2)
 
Цитата
Михаил С. пишет: ...выделенное красным - неверная запись.
Изменил диапазон следующим образом: =СУММЕСЛИ($D$3:$D$296;$D680;H$3:H$296), все заработало! самое интересное, что из 25-ти критериев (счетов) подобная ошибка проявилась только в одном случае - когда в диапазоне суммирования попалось число равное критерию отбора!

В любом случае большое спасибо за помощь!  :)
Страницы: 1
Читают тему (гостей: 1)
Наверх