Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
ДА/НЕТ в зависимости от значений в ячейках
 
Доброе время суток форумчане!
Подскажите пожаоуйста логическую формулу
Условие такое - если столбец А больше нуля и столбец Б больше нуля, а также если столбец В больше нуля но при условии что столбцы А и Б больше нуля, то ДА, в противном случае НЕТ.

Застрял на прописке условия столбца В.
 
Столбец весь больше 0? имеется ввиду сумма или просто наличие отрицательных чисел. Если Вы имели ввиду просто ячейки А1, B1, С1 то формула такая

Код
=ЕСЛИ(И(A1>0;B1>0);ЕСЛИ(C1>0;"Да";"Нет");"Нет")
 
или даже так проще

Код
=ЕСЛИ(И(A1>0;B1>0;C1>0);"Да";"Нет")
 
Изменено: Finswimmer - 26 Июн 2014 10:41:40
 
если у столбца В есть данные, но у столбцов А и Б нет данных, то НЕТ.
 
Может все-таки в соответствии с правилами пример выложите?
Формула все равно работает. Если в а1 и b1 нет даных, а в с1 есть то пишет нет.
В примере нужно показать каких данные исходные, какие могут быть варианты и что вы хотите получить в результате
Изменено: Finswimmer - 26 Июн 2014 11:38:33
 
Извините, случайно удалил последнее сообщение автора. Там была "Спасиба" всем  :)

Или не полностью описали задачу, или излишне описали задачу.
Какая разница, что в третьем столбце, если условие проверяется только на первых двух?
Если два первых значения положительны, то "да".
Если в одном из них не положительное, то "нет", независимо от того, сколько триллионов вписано в третьей ячейке.
 
Цитата
Если два первых значения положительны, то "да".
Если в одном из них не положительное, то "нет", независимо от того, сколько триллионов вписано в третьей ячейке.
Не совсем так.
Если в столбце "А" есть положительные цифры (больше нуля) и/или в столбце "B" есть положительные цифры, то тогда "ДА". Но при этом если в столбце "C" есть положительные цифры, то "ДА" только при условии что хоть в одном из столбцов "А" и/или "В" тоже есть положительные цифры.
 
И кстати, еще раз всем огромная благодарность за помощь!
 
Значит, третий в приоритете:
=ЕСЛИ(C1>0;ЕСЛИ(ИЛИ(A1>0;B1>0);"Да";"Нет");"Нет")
=ЕСЛИ(И(C1>0;ИЛИ(A1>0;B1>0));"Да";"Нет")
Страницы: 1
Читают тему (гостей: 1)