Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как учесть различный диапазон в условии формулы?
 
Доброго времени суток форумчане!

Есть формула =СУММЕСЛИМН($J6:$HH6;$J$3:$HH$3;$F6;$J$1:$HH$1;$A6;$J$5:$HH$5;$I6), где последний её аргумент (условие) выглядит как простое число, а в диапазоне условия есть разные значения, например 0-3 (стаж в месяцах) или от 6 до 24.

Как переделать последнее условие так, чтобы оно ориентировалось на диапазон, который может быть прописан по разному. Или вообще просто как учитывать диапазон?  
 
можно попробовать придумать но от вашей таблицы глаза разбегаются, какой нить аналог сделайте поменьше
Лень двигатель прогресса, доказано!!!
 
Убрал огромное количество курсов
 
как вариант приведите к единообразию 5 строку и можно пользовать ВПР
Лень двигатель прогресса, доказано!!!
 
Да, согласен. А если всё же стоит запрет на это? Т.е. шапку, которая у нас имеется вверху с инфой, мы не меняем?
 
тогда обоснуйте логику вот 5 в какой диапазон должна попасть в 3-6, в от 3 до 9, 3-12 или от 3 до 12 все типа диапазоны взяты из вашего первого файла
Лень двигатель прогресса, доказано!!!
 
Сотрудник со стажем 5 месяцев должен попасть во все вышеперечисленные вами диапазоны. Просто стаж это же лишь одно из 3х условий, для того чтобы определить нужные ли он курсы прошёл и сколько ещё нужно ему пройти курсов
 
тогда ни че другого не приходит как только вводить допстолбцы и на них ссылаться в условиях
Лень двигатель прогресса, доказано!!!
 
К сожалению и у меня была идея только через добавление доп столбцов...  
Страницы: 1
Читают тему (гостей: 1)