Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как вставить адрес из ячейки в формулу?
 
День добрый, граждане! Подскажите, как подставить в формулу не адреса ячеек, а значения указанные в них. В примере: в ячейках написаны адреса, их необходимо вставит в формулу, а вставляются адреса самих ячеек. Пример простой, сам файл более 500 000 вписывать вручную невыполнимо.
excel на практике в 3D-печати
 
Не с той стороны подход.
Адреса не нужны. В чем основная задача?
 
=СРЗНАЧ(ИНДЕКС(B2:B11;D4):ИНДЕКС(B2:B11;D5))
 
Прикрепил часть таблицы, смысл в том, что по каждому месяцу нужно рассчитать. Вопрос в адресах принципиален. количество дней в годах разное (диапазон лет). пробовал с переводом дат и времени в цифры - исчерпал ресурс.
excel на практике в 3D-печати
 
Вячеслав, уберите ссылку из подписи, нарушение правил.

По вопросу: формула не нравится?
 
убираю. понял. Формулу придется вбивать по 12 месяца, 9 населенным пунктам за 4 года))))
excel на практике в 3D-печати
 
Смотрите в пример  
Лень двигатель прогресса, доказано!!!
 
Цитата
Вячеслав написал: по 12 месяца, 9 населенным пунктам за 4 года
На мой взгляд, проще всего сводной с группировкой по месяцам и годам
 
Сергей, спасибо! ДВССЫЛ - то, что нужно! Ваш должник!
excel на практике в 3D-печати
 
Вячеслав, Вы не поняли. Сергей Вам показал использование ДВССЫЛ для решения Вашего прямого вопроса. Но этот путь ошибочен.
Вы преобразовываете данные в текст (АДРЕС), потом текст преобразовываете в ссылку (ДВССЫЛ). А это все вычисления. На таком объеме данных неизбежны тормоза.
Формула с ИНДЕКС/ПОИСК решает задачу проще и намного эффективнее.
 
Согласен, индекс проще, но объем данных предстоит объяснять людям далеким от excel, по этой причине я пошел путем кучи последовательно вытекающих друг из друга таблиц. Всем спасибо, все работает!  
excel на практике в 3D-печати
 
Сделаем жизнь сложнее! :)
Возможно, не нужно много "вытекающих друг из друга таблиц", если оптимизировать задачу.
Страницы: 1
Читают тему (гостей: 1)