Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнение двух таблиц и вывод повторяющихся значений
 
Добрый день уважаемые форумчане!
Подскажите пожалуйста, есть два файла, в каждом из этих файлов, в первом столбце есть числовое значение. Еще есть третий файл, в котором нужно, чтобы выводились эти числовые значения, которые есть в обоих файлах. Логика такая - Если это числовое значение есть в файле 1 и 2, то нужно отобразить это числовое значение в файле 3. Если числовое значение есть в файле 1 но нет в файле 2 (и наоборот), значение выводить не надо.
На всякий случай во вложении привел пример.
Помогите пожалуйста решить эту задачу.  
 
А можно нам прислать все тоже самое но 1 файл на трех листах ...три таблицы ..А вообще типа того =ЕСЛИ(ИЛИ(ЕНД(ВПР(Табл1);ВПР(Табл2));0;ВПР(Табл1))
 
Цитата
Микки написал: А можно нам прислать все тоже самое но 1 файл на трех листах ...три таблицы .
Конечно, во вложении.

Не совсем понимаю логику работы с ВПР в этом случае, если искомое значение заведомо неизвестно а требуется вывести только те значения, которые есть в таблицах 1 и 2.
 
См. вариант - макрос:
1. Запрос файла 1 и файла 2.
2. Построение таблицы на листе "Результат" с выводом в автоматически созданный каталог OUT.
 
Вариант формулой массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('2'!$A$1:$A$8;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(1/('2'!$A$2:$A$8=ТРАНСП('1'!$A$2:$A$10));9^9)*(СТРОКА($A$2:$A$8));СТРОКА(A1)));"")
 
Мотя, спасибо большое за Вашу работу! С макросами хороший вариант, но если бы я еще разбирался с VBA... Универсальный, мощный язык который позволит реализовать любые задумки, надо будет вникнуть, всё никак руки не дойдут...

[USER=5363]gling[/USER, спасибо за ответ, формула c виду рабочая, но пока не очень понимаю как она работает, буду разбираться. Спасибо!
 
Зачем вообще усложнять?
Протягиваете в первом (да в любом) файле/листе формулу
Код
=VLOOKUP(A1,'2'!A:A,1,0)
фильтруете по <>#N/A и копируете все видимые куда угодно. Минута работы на всё.
 
Цитата
tkreka написал: если бы я еще разбирался с VBA...
Ваши файлы - условные примеры для реализации задуманного алгоритма, поэтому Вам не удалось воспользоваться макросом для реальных файлов.
Прикрепите небольшие "куски" Ваших реальных файлов 1 и 2 для изменения макроса.
Замените "конфиденс" в них на "яблоки-груши". :)
Страницы: 1
Читают тему (гостей: 1)
Наверх