Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как подсчитать количество ячеек с датами, которые больше/меньше определённой даты
 
Добрый день.

Я имею таблицу с датами, мне нужно подсчитать количество ячеек с датами, которые (например) больше определённой даты.
Для этого попытался воспользоваться функцией  "СЧЁТЕСЛИ" (формула: =СЧЁТЕСЛИ(диапазон ячеек с датами;">ячейка с датой, с которой нужно сравнить")).
Но ничего не получается почему-то.

Можно было бы посчитать в отдельном столбце разность каждой даты в диапазоне со сравниваемой датой, а потом, воспользовавшись той же  функцией  "СЧЁТЕСЛИ" (формула: =СЧЁТЕСЛИ(диапазон ячеек с разностями дат;">0")), выяснить искомое количество ячеек.
Но и тут засада: многие даты в столбце стоят в объединённых ячейках или в столбце имеются пустые ячейки.

Вероятно, я где-то ошибся. Прошу помочь советом.  
Заранее спасибо!

P.S. Пример прилагаю.
 
Код
=СЧЁТЕСЛИ(A2:A19;">"&I1)
Согласие есть продукт при полном непротивлении сторон.
 
И не путайте I с J
 
Благодарю, а то я уж совсем замучился:)
 
Всем привет, подскажите мне тот же вопрос пожалуйста, вроде бы формулу проверила, все равно не считает((
 
Код
=СЧЁТЕСЛИ(TDSheet!A:A;"<="&A2)

Ссылка на ячейку ВСЕГДА должна быть ЗА кавычками после амперсанда. Т.е. в кавычка знак равенства "<=", потом амперсанд и ссылка на ячейку, с которой сравнить &A2

ps И кстати, знак равенства "меньше либо равно", поэтому "<=", а у вас "=<" - так тоже не будет считать))
Изменено: StepanWolkoff - 2 фев 2018 19:39:50
 
спасибо огромное! выручили))
 
Пожалуйста, объясните, почему для данной задачи надо использовать именно такое написание формулы, с амперсандом?
 
А если без него, то какой критерий?
 
Почему не проходит такой вариант =СЧЁТЕСЛИ(Лист1!D:D;"<=B1"), но при этом проходит вариант  =СЧЁТЕСЛИ(Лист1!D:D;"<=20.12.2019"). хотя в ячейке B1 формат даты?
Почему нужно использовать именно формат "<="&B1
 
AlexeyKV1, потому что B1 в кавычках распознаётся как текст, а не как ссылка на ячейку
 
потому что вы решили, что в этой записи =СЧЁТЕСЛИ(Лист1!D:D;"<=B1") что-то сподвигнет Excel отнестись к В1 как к ссылке на ячейку В1, а текстовая константа она и в Африке текстовая константа
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
AlexeyKV1,
Цитата
AlexeyKV1 но при этом проходит вариант  =СЧЁТЕСЛИ(Лист1!D:D;"<=20.12.2019"). хотя в ячейке B1 формат даты
В ячейке B1 формат даты, а в ячейках D:D какой формат, я подозреваю, что текстовый. Иначе не должен сравнивать, что бы сравнивалась дата с датой Ваша формула должна выглядеть вот так
=СЧЁТЕСЛИ(Лист1!D:D;"<=43819")
или как писали выше "<="&B1
Изменено: msi2102 - 25 дек 2019 15:12:30
 
с форматами ячеек все нормально. Я даже не сообразил, комент выше верный. По сути запись B1 воспринимает как текстовую константу. По этому и формула вниз не тянулась.
 
AlexeyKV1, проверьте на всякий случай формат в Столбце D. Дело в том, что иногда бывает, что стоит формат "дата", записано в формате "дата", а Excel понимает запись как текст. Поэтому попробуйте проверить, в любой ячейке столбца С или Е установите формат дата и только этого запишите значение как в столбце D (не копированием, а вручную) и простая формула =D5=C5 и если ИСТИНА то все в порядке. Просто формула =СЧЁТЕСЛИ(Лист1!D:D;"<=20.12.2019") сравнивает текст, а не дату. Excel не сравнивает даты как таковые он сравнивает значения этих дат.
Изменено: msi2102 - 25 дек 2019 15:52:39
 
msi2102,там с форматом все ок. Я с данными работал. Это даты, считается разность дат, и тд. Проблема выше сказана. Что при вводе формулы =СЧЁТЕСЛИ(Лист1!D:D;"<=B1")  воспринимается текст B1, а не значение ячейки B1. Хотя это несколько странно. Ведь формулу я забиваю через развернутую форму. Почему так  - "<=B1" переводит excel, для меня загадка. ведь я набиваю <=, а потом просто нажимаю на ячейку. По идее он сам должен был на мои действия в формулу вбить "<="&B1
 
Всем привет!
По описанной выше проблеме все понятно.
А если условие такое: нужно подсчитать количество ячеек с датами, которые (например) больше определённой даты, но меньше другой даты?
Например, есть дата 02.01.2021.
Она меньше, чем 03.01.2021, но больше, чем 31.12.2020.
Формула, описанная выше, поможет сделать подсчет в 1 месяце, но уже при переключении на другой - будет считать неправильно, т.к. прошедший месяц не должен учитываться. Тут-то и требуется второй параметр.

Имеется переключение месяца в ячейке K7 (для примера).
Интересует 2 строка после переключения K7. Если установлен месяц Февраль 2020, значит из диапазона A11:A15 считаются только февральские даты, т.е. ячейки A14 и A15. Если Март 2020, значит все даты по нулям.
 
=СЧЕТЕСЛИМН
 
Благодарю за подсказку, я знал о этой функции, но, видимо, заработался...
Все теперь отлично!
Прекрасного дня!
 
Добрый день.
Подскажите, как правильнее учесть.
Есть задача динамически считать сколько продаж было за неделю в каждом филиале по отдельности. В таблице собираются продажи текущего месяца, есть столбец формата 01.02.2021. Т.к. сегодня 12е число - то в файле пока продажи с 1 по 11 число. А через неделю будут заявки с 1 по 18 число,

Как можно без промежуточных вычислений - подсчитать продажи по неделям?
Пытался привязаться к формуле ДЕНЬ(Р:Р)=1 число, 2 число и т.д, но не получается
 
Цитата
dovos написал: сколько продаж было за неделю в каждом филиале по отдельности.
Вот и создайте тему с таким названием
Страницы: 1
Читают тему (гостей: 1)
Наверх