Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Коробка в коробке (проверить соответствие размеров), Необходимо сделать выборку по трем ячейкам, сравнивая их с тремя значениями.
 
Здравствуйте. Совсем запуталась с решением следующей задачи. Есть коробка X x Y x Z и есть три колонки в которых указаны размеры других коробок. Надо проверить каждую коробку влезет ли она (каким боком ее не положи) в основную коробку.
Я думала легко и сделала формулу =ЕСЛИ((И(B11<=$L$12;B11<=$M$12;B11<=$N$12)*ИЛИ(C11<=$L$12;C11<=$M$12;C11<=$N$12)*ИЛИ(D11<=$N$12;D11<=$N$12;D11<=$N$12));"In BOX";"No") но нет, она не работает. Может кто-нибудь подскажет, заранее спасибо.
Изменено: nuga - 1 Мар 2017 10:27:57
 
ну исходя из перестановок X,Y, Z N! - 3!=6 комбинаций "каким боком" , .
И(B11<=$L$12;B11<=$M$12;B11<=$N$12)*ИЛИ(C11 - вы что тут хотели получиь? если расшифроать то получается
B11<=$L$12  and B11<=$M$12 and B11<=$N$12 and (C11<=$L$12 OR C11<=$M$12 OR C11<=$N$12 ) ,,,, и это явно не то.
AND (И)  можно заменить умножением, OR (ИЛИ) сложением
 
Я уже все перепробовала, может и не ЕСЛИ совсем брать. Задача жизненная. Буду думать.
 
Так проверьте
Код
=ЕСЛИ(И(НАИБОЛЬШИЙ(C5:E5;{1;2;3})<=НАИБОЛЬШИЙ($K$12:$M$12;{1;2;3}));"In Box";"No")
 
вот вариант, сначала искомую коробку перевел в 6 вариантов, потом сравнил
 
Не смотрел что  у Виктора,

А ну, да примерно также , только я упихнул усе перестановки  в три массива.

Елена. Снимаю шляпу.
Изменено: БМВ - 1 Мар 2017 11:00:14 (Заменил файл)
 
СПАСИБО!!!!!!!!!!!!!!!!!!!!! Да, работают оба варианта. Наша группа спасена на эту пару по информатике. Спасибо.
Страницы: 1
Читают тему (гостей: 1)