Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет всех сумм итогов по условию
 
Есть список с количеством и названием.
Необходимо сделать динамический расчет итогов количества не общее,а по названиям.
Возможно ли такое сделать без макроса? С макросом я могу сделать, но требуется без макроса.
Пример прилагаю.
Изменено: BladzheR - 16 ноя 2017 11:16:30
 
BladzheR,
например, можно с помощью функции СУММЕСЛИ.
 
dext,вариант, а как задать,чтобы это если пробегало по всему столбцу?
Как будет происходить суммирование? Оно не будет обнуляться после каждого нахождения?
 
вариант, динамический диапазон можно спрятать в диспетчере имен, в ячейку I23 и протянуть вниз (для проверки добавить в конце списка еще позицию)
Код
=СУММЕСЛИ($C$4:ИНДЕКС($C:$C;ПОИСКПОЗ("ЯЯЯЯ";$C:$C;1));H23;$D$4:ИНДЕКС($D:$D;ПОИСКПОЗ("ЯЯЯЯ";$C:$C;1)))
Лень двигатель прогресса, доказано!!!
 
=СУММЕСЛИ(C:C;H23;D:D)
 
Вариант: без формул.
Изменено: Мотя - 16 ноя 2017 16:54:30
 
Всем спасибо!
Всё оказалось очень просто.
Страницы: 1
Читают тему (гостей: 1)
Наверх