Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: Пред. 1 2
RSS
Обновление 29.12.2020, Обновил двиг сайта и модуль форума в том числе
 
По поводу "недозагрузки" файлов: у меня за всё время было 2-3 раза - останавливалось на 90%. И пользователи в личку иногда жаловались на аналогичную проблему. Но это крайне трудно смоделировать - можно 100 раз пытаться и не поймать.
Алексей, а может это быть свящано с тем, что сервер в это время выполняет какие-либо операции? Фоновое копирования, например, или ещё что-то?
 
Тогда пока таймаут - тестируем дальше ...
Баги сюда со скринами и полным описанием ситуации, чтобы можно было смоделировать.
 
Цитата
Юрий М написал:
Алексей, а может это быть свящано с тем, что сервер в это время выполняет какие-либо операции? Фоновое копирования, например, или ещё что-то?
Не должно...
Давайте на всякий случай и время фиксировать.

PS
Кстати, а если сразу же попробовать этот же файл заново подцепить - нормально пройдёт?
 
Не по теме, но проблема старая: нет ли возможности сделать (при регистрации или редактирования профиля) проверку на уникальность логина?
 
Цитата
Алексей Вдовин написал:
а если сразу же попробовать этот же файл заново подцепить - нормально пройдёт?
Со второй попытки у меня получалось сразу.
 
Цитата
Алексей Вдовин: То есть в цитате?
в таком сообщении, как вот то, что я сейчас набираю
Цитата
Юрий М: Меня эта "иногда" ни разу не посещала ))
ну а у меня в день по несколько раз, при этом это не прерывание сессии и всё отправляется

Недогруз вложений также присутствует
Реквизиты для благодарности и контакты для связи — в профиле
 
Цитата
Юрий М написал:
Не по теме, но проблема старая: нет ли возможности сделать (при регистрации или редактирования профиля) проверку на уникальность логина?
Можно. Навскидку алгоритм такой:

Обработка события onchange (javascript), далее ajax запрос проверки на уникальность на сайт - там уже php скрипт всё проверяет и соответственно, результат уже обратно в браузер в подсказку (например, красным после поля с логином, либо справа от него).

В общем немного повозиться придётся - кастомизировать штатный компонент регистрации, т.к. штатных решений нет.  На такие задачи мне Николай отдельное ТЗ ставит, соответственно за отдельную плату.
 
Цитата
Алексей Вдовин: отдельное ТЗ … за отдельную плату
значит не скоро, походу, эта функция заработает — бюджет не резиновый, чай  :D
Изменено: Jack Famous - 12 янв 2021 13:44:57
Реквизиты для благодарности и контакты для связи — в профиле
 
Цитата
Алексей Вдовин написал:
кастомизировать штатный компонент регистрации
В таком случае при кажом обновлении это придётся делать заново? ((
 
Цитата
Jack Famous написал:
значит не скоро, походу, эта функция заработает — бюджет не резиновый, чай
Там не дорого обойдётся :) Думаю договоримся  
 
Цитата
Юрий М написал:
В таком случае при кажом обновлении эту придётся делать заново? ((
Нет, на регулярные обновления это не повлияет.
Только в том случае, если Битрикс выпустит новый компонент - а это врят ли...

Да и то в этом случае будет работать кастомизированный шаблон, а не новый, выпущенный Битриксом.
У кастомизированных шаблонов приоритет.
 
Просто удивительно, что Битрикс не предусмотрел эту проверку изначально.
 
Сейчас обнаружилось вот какая штуковина: при попытке отправить сообщение, пришлось 3 или 4 раза нажать на кнопку - не хотело отправляться.
А сейчас снова нормально.
 
Цитата
Юрий М написал:
Не по теме, но проблема старая: нет ли возможности сделать (при регистрации или редактирования профиля) проверку на уникальность логина?
Пока было время - сделал т.к. уверен, что Николай ТЗ всё равно поставил бы :)
Правда когда сделал проверку на логин, подумал, что аналогичная проверка на е-майл напрашивается ...

В общем готово! - просьба потестить
 
Цитата
Юрий М написал:
По поводу "недозагрузки" файлов: у меня за всё время было 2-3 раза - останавливалось на 90%
Вчера было. Попробовал удалить недозагруженный и загрузить заново, удалить удалил, а грузить больше не дал, пришлось перезайти в тему, после чего все получилось.
Цитата
Юрий М написал:
Сейчас обнаружилось вот какая штуковина: при попытке отправить сообщение, пришлось 3 или 4 раза нажать на кнопку - не хотело отправляться
С телефона часто такое бывает
 
Цитата
msi2102: грузить больше не дал, пришлось перезайти в тему,
часто такое и у меня на компе
Реквизиты для благодарности и контакты для связи — в профиле
 
Цитата
msi2102 написал:
Вчера было. Попробовал удалить недозагруженный и загрузить заново, удалить удалил, а грузить больше не дал, пришлось перезайти в тему, после чего все получилось.
Для чистоты эксперимента можно проблемный файл в эту ветку кинуть?
 
Адрес ТЕМЫ
Не помню точно какой из них:
Файл_1 или Файл_2
Думаю это не из-за файлов, потому что после перезагрузки темы тот же файл встал без проблем
 
попробую сразу оба подгрузить
 
Цитата
Алексей Вдовин написал:
попробую сразу оба подгрузить
Повторюсь, у меня они потом загрузились без проблем. Просто прочитал пост #31 и обратил внимание, что загрузка именно до 90%, у нас были разные файлы и навряд-ли 90% простое совпадение. Возможно это связано с временем отведенным на сессию. Сейчас, мне показалось, что время сессии уменьшилось.
 
Алексей Вдовин, в подтверждение работы Enter'а вы демонстрируете возможность переноса строки (хотя я не говорил, что он ВООБЩЕ не работает), в том, что файл не подгружается вы считаете виноватым файлы (хотя эти же файлы В ДРУГОЙ РАЗ подгружаются)  :D  :D  :D

Вам бы с другой стороны на проблемы посмотреть, что-ли  ;)
Реквизиты для благодарности и контакты для связи — в профиле
 
я пытаюсь воссоздать те условия, в результате которых проявляется ошибка
пока я её не смоделирую, работать над решением не получится
 
Алексей Вдовин, Не думаю что поможет, но если загрузка файла сразу пошла медленнее чем обычно, то на 99% она будет не успешной. так как такое замечал на двух совершенно разных системах (Notebook WiFi, Desktop Wired) то проблемы с каналом можно исключить. Судя по всему и движок браузера тоже не влияет.
По вопросам из тем форума, личку не читаю.
 
тест подгрузки файла с правами обычного пользователя
 
Желтое предупреждение об окончании времени сессии вижу периодически, но сообщение сохраняется (собака лаяла для порядка?)

Вот такое еще.
Добавляю файл - кричит предупреждением, из редактирования не выходит.
Ухожу сам - а сообщение, оказывется, сохранилось новое.
ошибка.png (30.28 КБ)
 
Вот опять загрузка только на 90%. При загрузке файла, появилась надпись на желтом фоне "Изменение полей формы не были сохранены: Восстановить автосохраненные значения?", при наборе текста этой записи не было. После нажатия кнопки ответить, ответ загрузился кроме файла. При изменении текста сообщения файл загрузился без проблем (поэтому можете пытаться смоделировать эту ошибку при загрузке этого файла, он загрузится без проблем). Если хотите смоделировать эту ситуацию, перед загрузкой файла сделайте небольшую паузу.
Ссылка на сообщение в форуме.
И ещё, очень долго стал грузиться при переходе на вкладку "ФОРУМ", остальные вкладки открываются нормально.
Снимок_7777.JPG (116.48 КБ)
Изменено: msi2102 - 18 янв 2021 09:26:08
 
Не знаю от обновления зависит или нет, но у меня в тегах CODE не всегда отображается символ подчеркивание "_". Для примера вот это сообщение вижу вот так:

Самое занятное, что у гражданина постом выше их видно, я скопировал его формулу и вытянул её в одну строку, в результате вот такое. Если в моем посте из строки формул скопировать этот невидимый символ, то в любое другое приложение вставляется "_". Значит он там точно есть, но его не видно.
Браузер огнелис 60.1.0esr (32-бит).
В Microsoft Edge 38.14393.1066.0 отображается нормально этот же пост.
Вот горшок пустой, он предмет простой...
 
Отображение на Android в Chrome барахлит
На iPhone и Safari такого не было
Скрин главной ветки
Скрин этого сообщения
Изменено: Jack Famous - 6 фев 2021 08:43:08
Реквизиты для благодарности и контакты для связи — в профиле
Страницы: Пред. 1 2
Читают тему (гостей: 1)
Наверх