Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Преобразование даты с русского в числовой формат
 
Здравствуйте. Как преобразовать дату с русским обозначением месяцев в числовой формат? Простым форматированием ячейки не удается. Плюс год добавляется соседней ячейкой - смотрим файл.
Сейчас орудую мистической формулой
Код
=ЕСЛИОШИБКА(--(ЛЕВБ(A1;2)&"/"&ПОИСК(ПСТР(A1;5;2);"ranebarprayunulugepctovec")/2);СЕГОДНЯ())

Как ее приспособить к русскому формату? Может кто нить объяснить значение букв в "ranebarprayunulugepctovec"? Если хоть один символ удалю/заменю - выводит неверную дату! ЧТО ЭТО ЗА МАГИЯ??? :)
 
Здрасьте. Пробуйте:
=ДАТА(B3;ПОИСК(ПСТР(A3;4;3);"ааянвфевмарапрмайиюниюлавгсеноктноядек")/3;ЛЕВСИМВ(A3;2))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Такой вариант не подходит?
Код
=ДАТАЗНАЧ(ЛЕВСИМВ(A3;6)&B3)

могут быть проблемы с маем, но все исправляется

еще вариант:
Код
=ДАТА(B3;(ПОИСК(ПСТР(A3;4;3);"янвфевмарапрмайиюниюлавгсеноктноядек")+2)/3;ЛЕВСИМВ(A3;2))
Изменено: MCH - 12 Июл 2019 13:45:13
 
Jesuit,
Цитата
Jesuit написал:
значение букв в "ranebarprayunulugepctovec"
Все буквы из названией месяцев в eng
 
Цитата
Jesuit написал:
ЧТО ЭТО ЗА МАГИЯ
Здесь на форуме есть виртуозы-формулисты (и у Вас в теме отметились), для которых дело чести  - минимизация длины формулы (правила игры - в первой теме данной ветви  "Избушка..."). Так вот, кто-то когда-то заметил, что комбинация второй и третьей буквы названий месяцев не повторяется ни в английском, ни в русском языке...
Владимир
 
Цитата
sokol92 написал:
комбинация второй и третьей буквы названий месяцев не повторяется ни в английском, ни в русском языке
ау )))
аже не огу ичего ругого аписать :D  
 
Все сложнее: aж е ог ич ру ап :D  
Владимир
 
епт...такой ощущение что мир заполнен Гарри Поттерами, а ты ЕДИНСТВЕННЫЙ МАГЛ в нем! )))
 
Цитата
sokol92 написал:
ни в английском, ни в русском языке...
правда это не всегда выполняется для других языков.
Цитата
sokol92 написал:
минимизация длины формулы
надо бережно относится к ресурсам даже если это пара байт :-)
Изменено: БМВ - 12 Июл 2019 15:30:10
 
Цитата
БМВ написал:
надо бережно относится к ресурсам
При этом надо помнить, что не всегда краткость формулы = оптимальная скорость расчетов.
Вот горшок пустой, он предмет простой...
 
PooHkrd, согласен, но в данном случае краткость как раз в +
 
СПАСИБО ВСЕМ ОГРОМНОЕ! так все просто оказалось, а такую воду мутили...))))
Страницы: 1
Читают тему (гостей: 1)
Наверх