Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
объединение ячеек по признаку в строку (не сцепляя)
 
Здравствуйте!
поискал подобное на просторах интернета, ничего не нашел, возможно плохо искал.
задача такая: необходимо ячейки по общему признаку собрать в одной строке друг за другом (не сцепляя в одну ячейку).
помогите, пожалуйста, как можно реализовать. пример во вложении
 
maxmax1111,

в С29 и протянуть вниз вправо.
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС(ИНДЕКС($B$6:$F$22;1;ПОИСКПОЗ(C$28;$B$5:$F$5;0)):ИНДЕКС($B$6:$F$22;СЧЁТЕСЛИ($B$6:$B$22;"<>"&"");ПОИСКПОЗ(C$28;$B$5:$F$5;0));ПОИСКПОЗ($B29;$B$6:$B$22;0);1):ИНДЕКС(ИНДЕКС($B$6:$F$22;1;ПОИСКПОЗ(C$28;$B$5:$F$5;0)):ИНДЕКС($B$6:$F$22;СЧЁТЕСЛИ($B$6:$B$22;"<>"&"");ПОИСКПОЗ(C$28;$B$5:$F$5;0));ПОИСКПОЗ($B29;$B$6:$B$22;0)+СЧЁТЕСЛИ($B$6:$B$22;$B29)-1;1);СЧЁТЕСЛИ($A$28:C$28;C$28);1);"")
 
спасибо!!!
а, допустим, у нас n-е количество строк. можно ли как то автоматизировать, чтобы шапку продлять формулой? или уже надо с макросами работать?
 
maxmax1111, ну наверное можно...просто условие прописать какое нибудь что бы если пусто то тоже пусто и если не пусто то =томуто
Страницы: 1
Читают тему (гостей: 1)
Наверх