Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Отметить неделю в списке дат
 
Здравствуйте, подскажите пожалуйста, как составить формулу, которая бы отмечала подряд идущие даты(именно семь дней подряд) для отдельно взятой фирмы
В файле я для примера проставила 1 напротив таких сочетаний
 
Доброе время суток
Цитата
l-lisa написал:
именно семь дней подряд
А что если будет более 7 дней подряд, тогда какие семь дней из этой последовательности нужно помечать единицей?
 
Кросс
Алексей М.
 
первые семь дней только , а можно и все если будет больше семи, главное , чтобы не меньше семи
 
Версия, на Power Query, пока формулисты двух форумов думают. :)
 
спасибо, а как это настроить то в Power Query? я никогда им не пользовалась(
 
Цитата
l-lisa написал:  а как это настроить то в Power Query?
В вашем файле уже настроено.
Цитата
l-lisa написал:  я никогда им не пользовалась(
Ничто не мешает начать: Power Query — обзор и обучение, Скульптор данных в Excel с Power Query, для начала.
 
Цитата
Андрей VG написал:
В вашем файле уже настроено.
У меня просто  эта надстройка не установлена, версия эксель старая
 
Цитата
l-lisa написал:
версия эксель старая
Тогда ждите формулистов.
 
Цитата
l-lisa написал:
версия эксель старая
2007?
как ваиант, массивная формула
Код
=ЕСЛИОШИБКА(СУММ(ЕСЛИ(И(C3:C8=C2+СТРОКА($1:$6);A3:A8=A2);1;И(C2=Ч(+C1)+1;A1=A2;E1=1))^{1;0};-1);"")
 
Андрей Лящук, спасибо, очень классная формула
Вы могли бы мне пояснить вот эту часть:
Код
И(C2=Ч(+C1)+1;A1=A2;E1=1))^{1;0};-1)

особенно: ^{1;0}
 
Покороче формула. Массивная
Код
=И(C3:C8=C2+{1:2:3:4:5:6};A3:A8=A2)+(C2=Ч(C1)+(A1=A2))*(D1=1)
Алексей М.
 
АlехМ, спасибо большое!
Страницы: 1
Читают тему (гостей: 1)
Наверх