Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Функция ЕСЛИ с 5 условиями, Проверка условий и определения статуса
 
Добрый день!

Прописать формулу для 1 статуса несложно, но как быть если необходимо указать сразу 5 условия? В столбце Состояние лотов автоматически необходимо прописать формулу используя функцию ЕСЛИ которая будет учитывать критерии определения статуса лота.

Состояния лота может иметь 1 статус из 5:
1. Подписанные договора по лотам (Условие: если в столбце № договора есть данные);
2. В стадии составления и согласования договоров (Условие: если в столбце № договора нет данных, но данные есть в столбце Подрядчик);
3. В стадии проведения конкурсных процедур (Условие: если в столбце № договора нет данных, в столбце Подрядчик нет данных, но данные есть в столбце СЗ о проведении закупочных процедур);
4. Составлены ведомости, но не выпущены сметы (Условие: если в столбце № договора нет данных, в столбце Подрядчик нет данных, в столбце СЗ о проведении закупочных процедур нет данных, но данные есть в столбце Ведомости);
5. Не составлены дефектные ведомости (Условие: если в столбце № договора нет данных, в столбце Подрядчик нет данных, в столбце СЗ о проведении закупочных процедур нет данных, в столбце Ведомости нет данных).
 
Maxim909 Gorbunov,  используйте и
(Александр)
 
Назание темы должно отражать задачу, а не выбранную функцию. Предлагайте. Заменят модераторы
 
Цитата
Mershik написал:
Maxim909 Gorbunov ,  используйте и
Mershik, не получается прописать несколько условия, первое условие, если ячейка не пустая, то статус определяется Подписанные договора по лотам тогда функция будет =ЕСЛИ(НЕ(F3=""); "Подписанные договора по лотам").

Получилось 5 логических выражений, но выдает ошибку и не считает:
=ЕСЛИ(И((НЕ(F3="");"Подписанные договора по лотам"); ЕСЛИ(НЕ(G3="");"В стадии составления договоров");ЕСЛИ(НЕ(E3="");"В стадии проведения конкурсных процедур"); ЕСЛИ(НЕ(D3="");"Не сформированы СЗ от СП на инициацию");ЕСЛИ(НЕ(C3="");"Составлены д.ведомости, но не выпущены сметы"; "Не составлены дефектные ведомости")
Изменено: Maxim909 Gorbunov - 30 Июн 2020 08:55:36
 
Maxim909 Gorbunov, #3 вы прочли? Тут ведь не только устами младенца глаголит истина, но еще его руками и темы закрываются.
Условий у Вас не 5, а больше по тому что у каждого условия есть еше вес или однозначно последовательность заполения.
По вопросам из тем форума, личку не читаю.
 
А что с названием? не написано же в теме "ПОМОГИТЕ, НЕ УМЕЮ" какая-то уже бюрократия в интернете.

В итоге просидел полдня и формула заработала

=ЕСЛИ(НЕ(F3="");"Подписанные договора по лотам"; ЕСЛИ(НЕ(G3="");"В стадии составления и согласования договоров"; ЕСЛИ(НЕ(E3="");"В стадии проведения конкурсных процедур";ЕСЛИ(И(C3=D3;D3<>0);"Не сформированы СЗ от СП на инициацию";ЕСЛИ(И(P7=O7;P7<>0);"Составлены д.ведомости, но не выпущены сметы";"Не составлены дефектные ведомости")))))
 
Цитата
Maxim909 Gorbunov написал:
акая-то уже бюрократия в интернете.
это не бюрократия а точность
У вас не одна а несколько функций в каждой одно условие, а в теме обратное.
По вопросам из тем форума, личку не читаю.
 
Maxim909 Gorbunov, это не бюрократия, а помощь будущим посетителям: по названию темы решают, стоит ли терять время на посещение. ЕСЛИ может применяться в тысячах различных задач. Поэтому - зашли за помощью, помогите и Вы другим.
Помощь скрыта до устранения замечания.

AndreyЧella, у нас такое неписанное правило: или воздержаться от помощи, или самому предложить адекватное название темы
Страницы: 1
Читают тему (гостей: 1)
Наверх