Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнить два массива и высести значение работает/не работает
 
Здравствуйте. Появился такой вопрос. Есть два массива с данными (пример прикреплен). Нужно проверить наличие компаний в Листе 3 и сравнить расходы по этим компания, если расходы равны, то копания НЕ работает, если расход отличается, то компания работает.Так же если у компании расход 0 или компания отсутствует на Листе 3 - то компания также НЕ работает - этот вопрос я решил

Что нужно доработать. На примере строки 19 - у компании есть расход, но она отсутствует на проверочном Листе 3. Как доработать формулу - что бы было указано в данной строке как рабочая компания?
Надеюсь, не слишком сложно написал ))
Помогите кто может
 
k-kayn, так?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;Лист3!A:B;2;0)=B2;"не работает";"работает");"работает")
Изменено: Mershik - 16 сен 2020 17:20:03
 
Цитата
Mershik написал:
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;Лист3!A:B;2;0)=B2;"не работает";"работает");"работает")
к сожалению нет, у меня похожая формула, но тогда все компании, включая  которых нет на Листе 3 и включая у которых расход 0 на Листе 2 - будут  отображаться как "работает", а нужно только те компании у которых есть  расход на листе 2, но их нет на проверочном Листе 3
 
k-kayn, тогда так?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;Лист3!A:B;2;0)=B2;"не работает";"работает");ЕСЛИ(B2=0;"не работает";"работает"))
 
теперь все работает! спасибо огромное за помощь! ))
Страницы: 1
Читают тему (гостей: 1)
Наверх