Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет среднего по критерию из столбца и рядка
 
Добрый день))
Подскажите, как подсчитать среднее значение после проведения опроса.
Данные опроса на листе 3.
В первой таблице необходимо подсчитать среднее по тому как каждое подразделение оценило другое. (Лист 5)
А во второй таблице посчитать посчитать среднее по критериям по каждому подразделению. Критерий №1 выделен цветом, за ним критерий №2 и.т.д. (Лист 5)
Если клетка пуска не брать ее в расчет
Изменено: Evgenii Kov - 8 апр 2021 14:53:49
 
Формула массива
Код
C6    =СУММ(($B6=Лист3!$A$3:$A$49)*(C$5=Лист3!$B$2:$CS$2)*(Лист3!$B$3:$CS$49))/СУММ(($B6=Лист3!$A$3:$A$49)*(C$5=Лист3!$B$2:$CS$2)*(Лист3!$B$3:$CS$49<>"")*1)
C25   =СУММ(($B25=Лист3!$A$3:$A$49)*(ОСТАТ(СТОЛБЕЦ(Лист3!$B$3:$CS$49)-2;8)=СТОЛБЕЦ()-3)*(Лист3!$B$3:$CS$49))/СУММ(($B25=Лист3!$A$3:$A$49)*(ОСТАТ(СТОЛБЕЦ(Лист3!$B$3:$CS$49)-2;8)=СТОЛБЕЦ()-3)*(Лист3!$B$3:$CS$49<>"")*1)
Изменено: МатросНаЗебре - 8 апр 2021 15:03:21
 
МатросНаЗебре, в таблицу вставил. что то не работает. а вы не моглиб скинуть пример
 
Вставляйте как формулу массива. Ctrl+Shift+Enter.
 
МатросНаЗебре, спасибо. все работает.
понял что мне  надо подтянуть этот раздел ))
 
МатросНаЗебре, а если я хочу перенести две таблицы с формулами на лист 3 мне нужно только поменять критерии и убрать названия листов в формуле ?
 
В этой теме - подсчет среднего, а не перенос
Страницы: 1
Читают тему (гостей: 1)
Наверх