Страницы: 1
RSS
Как прописать формулу в VBA, используя Cells и переменные
 
Коллеги, добрый день
немного более сложная формула, и методики, предложенные здесь, не срабатывают
https://www.planetaexcel.ru/forum/index.php?PAGE_NAME=read&FID=1&TID=150470&...
пробовал всё от Iгор Гончаренко

во вложении пример - таблица с продуктами, количества, цены
задача - расчет средневзвешенной цены по каждому продукту
то есть справа формула СУММПРОИЗВ/СУММ, она должна была ехать по столбцу и, опираясь на переменные, менять размер диапазона
для картофеля свой диапазон
для морковки свой
и т.д.

и вот не получается заменить этими переменными в формуле стиля RC
ни через метод Address
ни через Replace
и никак вообще - ошибки в коде, не понимает двоеточие, закрыть выражение требует и миллион других причин

буду признателен за подсказки
 
Ответил в ЭТОЙ теме
Согласие есть продукт при полном непротивлении сторон.

Контакты, благодарности
 
А Вам точно макрос-формула нужна (лучше тогда свою функцию написать)

Ну через формулу...
СУММ - можно закладывать внутрь СУММПРОИЗВ
=СУММПРОИЗВ(B2:B7;C2:C7/СУММ(C2:C7))

СУММПРОИЗВ - поддерживает условие
=СУММПРОИЗВ((A2:A18=A2)*B2:B18*C2:C18)

СУММ по условию - СУММЕСЛИ
=СУММПРОИЗВ(($A$2:$A$18=A2)*$B$2:$B$18*$C$2:$C$18/СУММЕСЛИ($A$2:$A$18;A2;$C$2:$C$18))

Если через VBA
см файл
 
Цитата
написал:
Если через VBAсм файл
да, спасибо, тоже работает!
хотя совершенно другое решение, вчера вот здесь предложили
https://www.planetaexcel.ru/forum/index.php?PAGE_NAME=read&FID=1&TID=150470&...

всё беру на карандаш) век живи - век учись
Страницы: 1
Наверх