Страницы: 1
RSS
Суммирование по нескольким условиям, если идентификатор аналогичный, Работа с формулами
 
Добрый день.
Прошу подсказать пусть решения:
Есть вкладка накопитель, куда будет вноситься перечень поставленного материала, но проблема в то, что очень часто, "наименование", "Номер" и другие идентификаторы - будут  идентичные, а кол-во разное.
Во вкладке "Выдача", будет формироваться список на выдачу, который должен вычитать объем из колонки "Приход" (вкладка накопитель) и показывать остаток, но если идентификаторы одинаковые, вычитание идет по всем типовым названиям, возможно как то реализовать, последовательное вычитание для позиций столбца В вкладки накопитель?  
 
Здравствуйте. Можно попробовать ( если Excel 2021+, зеленые ячейки):
Код
=ИНДЕКС(ФИЛЬТР(Накопитель!$F$2:$F$12;(Накопитель!$G$2:$G$12=Выдача!A2)*(Накопитель!$B$2:$B$12=Выдача!E2));СЧЁТЕСЛИМН($A$2:$A2;A2;$E$2:$E2;E2))
Для других версий
Код
=ИНДЕКС(Накопитель!$F$2:$F$8;НАИМЕНЬШИЙ(ЕСЛИ((Накопитель!$G$2:$G$8=Выдача!A2)*(Накопитель!$B$2:$B$8=Выдача!E2);СТРОКА(Накопитель!$A$2:$A$8)-СТРОКА(Накопитель!$A$1));СЧЁТЕСЛИМН($A$2:$A2;A2;$E$2:$E2;E2)))
(синии ячейки)
Изменено: R091n - 23.02.2024 15:27:48
Страницы: 1
Наверх