Страницы: 1
RSS
Перенос данных из одного столбца в строки при изменении данных, Разбивка данных из одного столбца на строки с учетом изменения данных в столбце
 
Добрый день! Помогите, пожалуйста, "разбить" данные из столба С на строки с учетом изменения даты в столбце А. Т.е. должно получиться 31 строка (кол-во дней в месяце) с 24 столбцами (часов в сутки) с данными по каждому дню. Какими функциями можно это сделать? Спасибо!
 
Georgina, сводная таблица
или вариант 365
365
Изменено: AlienSx - 12.04.2024 11:38:40
Пришелец-прораб.
 
Добрый день.
Формула
Код
=ИНДЕКС(исх!$C$2:$C$745;(СТРОКА()-2)*24+СТОЛБЕЦ())
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Вариант формулой.
Код
=СУММЕСЛИМН(исх!$C:$C;исх!$A:$A;ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(СЕГОДНЯ())-1;СТРОКА(1:1));исх!$B:$B;ВРЕМЯ(СТОЛБЕЦ();0;0))
 
Ещё вариант макросом (добавил комментарии в код):
Скрытый текст
 
Спасибо за помощь!
Страницы: 1
Наверх