Страницы: 1
RSS
Применение формулы объединения данных из трех ячеек в одну и так повторить на весь столбец., В столбце с данными каждые три ячейки нужно соединить текст в одну. 3=1;3=1; 3=1, как сделать чтобы формула применялась для большого количества ячеек в рамках одного столбца?
 
При копировании формулы на весь столбец получается следующее:
=СЦЕП(А1:А3)
=СЦЕП(А2:А4)
=СЦЕП(А3:А5)

необходимо так:
=СЦЕП(А1:А3)
=СЦЕП(А4:А6)
=СЦЕП(А7:А9)

как сделать автоматически на весь столбец не прописывая сцепку каждой ячейки?
 
В Б1:
=СЦЕПИТЬ(СМЕЩ(A1; (СТРОКА()-1)*2; 0); СМЕЩ(A2; (СТРОКА()-1)*2; 0); СМЕЩ(A3; (СТРОКА()-1)*2; 0))
И скопировать вниз
Изменено: DAB - 12.04.2024 18:28:45
 
Спасибо! Все сработало! :)  
 
Код
=ИНДЕКС(A:A;(СТРОКА()-1)*3+1)&ИНДЕКС(A:A;(СТРОКА()-1)*3+2)&ИНДЕКС(A:A;(СТРОКА()-1)*3+3)
Алексей М.
 
Код
=СЦЕП(ИНДЕКС(A:A;СТРОКА($1:$3)+(СТРОКА()-1)*3))
 
Цитата
Тимофеев:  =СЦЕП(ИНДЕКС(A:A;СТРОКА($1:$3)+(СТРОКА()-1)*3))
напрашивается "раскрыть скобки"
=СЦЕП(ИНДЕКС(A:A;3*СТРОКА()-{2:1:0}))
Страницы: 1
Наверх