Страницы: 1
RSS
Подстановка значения в зависимости от заданного диапазона дат, Как обеспечить "подтягивание" в нужный столбец данных, соответствующих определенному временному диапазону
 
Добрый день, уважаемые форумчане,

Возник вопрос в связи со сложностью создания формулы, которая позволяла бы "подтягивать" значения в определенный столбец в соответствии с заданными параметрами даты. К сожалению, идентичной темы не нашел на форуме, но если что-то пропустил, буду рад переадресации на нужную тему.

В чем сложности: есть календарь на год по дням, состоящий из двух столбцов - дата и название мероприятия. Рядом есть список мероприятий в формате название-дата начала-дата окончания. Необходимо, чтобы при добавлении мероприятий в список мероприятий названия мероприятий автоматически проставлялись в календарь в столбец с названием мероприятия. Пытался делать формулы на основе формул индекс/поискпоз, миксовать их с фукнцией если, использовать впр, но ничего не получается. Буду благодарен за помощь!
Изменено: olegkorr - 21.05.2024 14:18:32
 
День добрый
см файл
 
Код
=ИНДЕКС($D$1:$D$6;ПОИСКПОЗ(A2;E:E;1))
В первом приближении.
 
Код
=ЕСЛИ(A2<=ИНДЕКС($F$1:$F$6;ПОИСКПОЗ(A2;E:E;1));ИНДЕКС($D$1:$D$6;ПОИСКПОЗ(A2;E:E;1));"")
Во втором приближении.
 
Большое спасибо, очень выручили Павел \Ʌ/, МатросНаЗебре !
Страницы: 1
Наверх