Страницы: 1
RSS
Сумма дробей
 
Подскажите пожалуйста, как суммировать из Листа2 дроби (которые загружаются из НЕТА в текстовом формате (так нужно)) на Лист1 в одну ячейку? Спасибо.
 
как то так наверное
Лень двигатель прогресса, доказано!!!
 
Спасибо. Первый вариант подходит. А со вторым чуть не понятно: хочется выражение 3/2.
 
Кстати, если две дроби 2/1 + 2/1: выдаёт на Листе1 ответ 2, а хочется 4/2.
 
Код
 =СУММ(--ЛЕВСИМВ(Лист2!A7:A8;ПОИСК("/";Лист2!A7:A8;1)-1))&"/"&СУММ(--ПОДСТАВИТЬ(Лист2!A7:A8;ЛЕВСИМВ(Лист2!A7:A8;ПОИСК("/";Лист2!A7:A8;1));""))
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВСИМВ(Лист2!A9:A10;ПОИСК("/";Лист2!A9:A10;1)-1);--(Лист2!A9:A10)))&"/"&СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(Лист2!A9:A10;ЛЕВСИМВ(Лист2!A9:A10;ПОИСК("/";Лист2!A9:A10;1));"");0))
Лень двигатель прогресса, доказано!!!
 
Цитата
yuras11 пишет: 2/1 + 2/1: выдаёт на Листе1 ответ 2, а хочется 4/2.
по правилам математики 4/2 не получится ))) правильный ответ будет 4/1
 
Здравствуйте! Подскажите пожалуйста, как суммировать числа поставленные через дробь? Заранее спасибо!
 
gargon.88, Такой вариант устроит? (см файл)
 
Огромное спасибо Михаил!!!
 
Ребят огромное спасибо Всем вам!!! И еще раз простите за доставленные неудобства!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх