Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 След.
Сумма 12 последовательных ячеек в диапазоне из 36 ячеек, если сумма этих 12 ячеек превышает конкретное значение
 
Как вариант УФ:
Код
=ABS(СТОЛБЕЦ()-МИН(ЕСЛИ(МУМНОЖ((СТОЛБЕЦ($B:$AK)>СТРОКА($1:$25))*(СТОЛБЕЦ($B:$AK)<СТРОКА($14:$38))*$B3:$AK3;1^СТРОКА(1:36))>1000000;СТРОКА($7:$31);99))-1/2)<6
Количество повторов значений без учёта повторов по другому критерию, Формулой без дополнительного столбца
 
И Вам, здравствуйте!
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИМН(A$2:A$13;A$2:A$13;B$2:B$13;B2);))

*Или так:

Код
=СУММ(ЕСЛИ(B$2:B$13=B2;1/СЧЁТЕСЛИ(A$2:A$13;A$2:A$13))) 

**В верхних формулах будут ошибки, если для другого code будет тот же id Надо так:

Код
=СУММ(ЕСЛИ(B$2:B$13=B2;1/СЧЁТЕСЛИМН(A$2:A$13;A$2:A$13;B$2:B$13;B2)))
Изменено: Светлый - 6 Дек 2019 11:06:16
Ввод в Excel тригонометрической функции, Помощь с вводом.
 
И как вариант:
Код
=2*СУММ((4*A2^2)^{0;1;0;1}/TAN(ПИ()^2/4-A2^2)^{0;1;2;3}) 

*Даже так:

Код
=2*СУММ((2*A2)^{0;2;0;2}/TAN(ПИ()^2/4-A2^2)^{0;1;2;3}) 

**

Код
=2*СУММ(1;(2*A2)^{2;0;2}/TAN(ПИ()^2/4-A2^2)^{1;2;3})
Изменено: Светлый - 5 Дек 2019 10:54:49
Ввод в Excel тригонометрической функции, Помощь с вводом.
 
Такое написание недопустимо +1)(^2) скобки вокруг двойки лишние. Формула вообще не соответствует картинке. Лишние /2 , нет +2
* также пропущен знак умножения в 2(( . Про x уже написали. Много лишних скобок.
** В соответствии с картинкой:
Код
=(2*TAN(ПИ()^2/4-A2^2)^2+2)/TAN(ПИ()^2/4-A2^2)^2+8*A2^2*(TAN(ПИ()^2/4-A2^2)^2+1)^2/TAN(ПИ()^2/4-A2^2)^3-8*A2^2*(TAN(ПИ()^2/4-A2^2)^2+1)/TAN(ПИ()^2/4-A2^2)

Изменено: Светлый - 4 Дек 2019 12:49:04
Суммарные габариты по правилу
 
Цитата
ki-ru написал:
Удивительно, не думал что кто-то сможет так быстро решить
Ещё и соревнование устроили. Совместными усилиями получили короткую формулу. Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=ПОДСТАВИТЬ(ТЕКСТ(СУММ(НАИБОЛЬШИЙ(ABS(НАИМЕНЬШИЙ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2:B2);"х";"x");"x";"      ");{1:9:17};*{1;-1};{1;6:2;5:3;4})*10^{0:4:8});{1:2:3:5}));"0x0000x0000");"x0";"x") 

Если нужно, можно и по другому алгоритму упаковку рассчитать. По минимальному объёму. И не обязательно получится сумма меньших сторон:

Код
=ПРОСМОТР(2;1/(МИН(МУМНОЖ(LN(ИНДЕКС(ЕСЛИ(-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"      ");{1:9:17};8)<-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"       ");{1;10;19};9);ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"      ");{1:9:17};8);ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"       ");{1;10;19};9));Ч(ИНДЕКС({2;3:2;3:2;3:2;3:2;3:3;2:1;3:3;1:1;3:3;1:1;3:3;1:1;2:2;1:1;2:2;1:1;2:2;1};));Ч(ИНДЕКС({2;3:3;2:1;3:3;1:1;2:1;2:2;3:2;3:1;3:1;3:1;2:1;2:2;3:2;3:1;3:1;3:1;2:1;2};))));{1:1})+LN(ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"      ");{1:9:17};8);Ч(ИНДЕКС(СТРОКА($6:$23)/6;)))+ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"      ");{1:9:17};8);Ч(ИНДЕКС(ОСТАТ(СТРОКА($6:$23)/2;3)+1;)))))=МУМНОЖ(LN(ИНДЕКС(ЕСЛИ(-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"      ");{1:9:17};8)<-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"       ");{1;10;19};9);ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"       ");{1;10;19};9));Ч(ИНДЕКС({2;3:2;3:2;3:2;3:2;3:3;2:1;3:3;1:1;3:3;1:1;3:3;1:1;2:2;1:1;2:2;1:1;2:2;1};));Ч(ИНДЕКС({2;3:3;2:1;3:3;1:1;2:1;2:2;3:2;3:1;3:1;3:1;2:1;2:2;3:2;3:1;3:1;3:1;2:1;2};))));{1:1})+LN(ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"      ");{1:9:17};8);Ч(ИНДЕКС(СТРОКА($6:$23)/6;)))+ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"      ");{1:9:17};8);Ч(ИНДЕКС(ОСТАТ(СТРОКА($6:$23)/2;3)+1;)))));ПОДСТАВИТЬ(ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"      ");{1:9:17};8);Ч(ИНДЕКС(СТРОКА($6:$23)/6;)))+ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"      ");{1:9:17};8);Ч(ИНДЕКС(ОСТАТ(СТРОКА($6:$23)/2;3)+1;)))&"x"&ТЕКСТ(МУМНОЖ(ИНДЕКС(--ЕСЛИ(-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"      ");{1:9:17};8)<-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"       ");{1;10;19};9);ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"      ");{1:9:17};8);ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"       ");{1;10;19};9));Ч(ИНДЕКС({2;3:2;3:2;3:2;3:2;3:3;2:1;3:3;1:1;3:3;1:1;3:3;1:1;2:2;1:1;2:2;1:1;2:2;1};));Ч(ИНДЕКС({2;3:3;2:1;3:3;1:1;2:1;2:2;3:2;3:1;3:1;3:1;2:1;2:2;3:2;3:1;3:1;3:1;2:1;2};)));10^{4:0});"0x0000");"x0";"x"))

Суммарные габариты по правилу
 
Цитата
БМВ написал:
и коротенько
Можно ещё короче:
-МИН(-ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(AR3:AS3;"x";"х");"х";ПОВТОР(" ";99));{0:1:2}*99+1;99))
Суммарные габариты по правилу
 
Цитата
БМВ написал:
Очень похоже на то что у Светлого
Да, только без SMALL в третьем фрагменте, если речь идёт о первой формуле. А большая формула ищет минимальный объём полным перебором.
Цитата
БМВ написал:
пример не прикрепил
У меня уже файлов накопилось море. Не хочу плодить их без нужды. Но постараюсь специально для медведя прикладывать.
Суммарные габариты по правилу
 
Цитата
Wild.Godlike написал:
1177 знаков формула....это самое гигантское что я встречал за всё время О_О
А как Вам формула больше 4000 знаков?
Код
=ПРОСМОТР(1;1/(МИН((ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({1:1:1:1:1:1:2:2:2:2:2:2:3:3:3:3:3:3};)))+ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({1:1:2:2:3:3:1:1:2:2:3:3:1:1:2:2:3:3};))))*ЕСЛИ(-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:2:2:2:2:3:1:3:1:3:1:3:1:2:1:2:1:2};)))<-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:3:1:3:1:1:2:2:1:1:1:1:2:2:1:1:1:1};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:2:2:2:2:3:1:3:1:3:1:3:1:2:1:2:1:2};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:3:1:3:1:1:2:2:1:1:1:1:2:2:1:1:1:1};))))*ЕСЛИ(-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:3:3:3:3:2:3:1:3:1:3:1:2:1:2:1:2:1};)))<-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:2:3:1:2:2:3:3:3:3:2:2:3:3:3:3:2:2};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:3:3:3:3:2:3:1:3:1:3:1:2:1:2:1:2:1};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:2:3:1:2:2:3:3:3:3:2:2:3:3:3:3:2:2};)))))=(ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({1:1:1:1:1:1:2:2:2:2:2:2:3:3:3:3:3:3};)))+ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({1:1:2:2:3:3:1:1:2:2:3:3:1:1:2:2:3:3};))))*ЕСЛИ(-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:2:2:2:2:3:1:3:1:3:1:3:1:2:1:2:1:2};)))<-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:3:1:3:1:1:2:2:1:1:1:1:2:2:1:1:1:1};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:2:2:2:2:3:1:3:1:3:1:3:1:2:1:2:1:2};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:3:1:3:1:1:2:2:1:1:1:1:2:2:1:1:1:1};))))*ЕСЛИ(-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:3:3:3:3:2:3:1:3:1:3:1:2:1:2:1:2:1};)))<-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:2:3:1:2:2:3:3:3:3:2:2:3:3:3:3:2:2};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:3:3:3:3:2:3:1:3:1:3:1:2:1:2:1:2:1};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:2:3:1:2:2:3:3:3:3:2:2:3:3:3:3:2:2};)))));(ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({1:1:1:1:1:1:2:2:2:2:2:2:3:3:3:3:3:3};)))+ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({1:1:2:2:3:3:1:1:2:2:3:3:1:1:2:2:3:3};))))&"x"&--ЕСЛИ(-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:2:2:2:2:3:1:3:1:3:1:3:1:2:1:2:1:2};)))<-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:3:1:3:1:1:2:2:1:1:1:1:2:2:1:1:1:1};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:2:2:2:2:3:1:3:1:3:1:3:1:2:1:2:1:2};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({2:3:1:3:1:1:2:2:1:1:1:1:2:2:1:1:1:1};))))&"x"&--ЕСЛИ(-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:3:3:3:3:2:3:1:3:1:3:1:2:1:2:1:2:1};)))<-ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:2:3:1:2:2:3:3:3:3:2:2:3:3:3:3:2:2};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(A2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:3:3:3:3:2:3:1:3:1:3:1:2:1:2:1:2:1};)));ИНДЕКС(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(B2);"х";"x");"x";"        ");{1:10:19};9);Ч(ИНДЕКС({3:2:3:1:2:2:3:3:3:3:2:2:3:3:3:3:2:2};)))))
Находит наименьший объём по габаритам двух приставленных коробок. Не обязательно самыми тонкими сторонами. И ещё будет решение вопроса темы более короткими формулами.
Суммарные габариты по правилу
 
Обнаружил у себя в формуле ошибку. Лечится удалением одного пробела из всех "         " фрагментов формулы.
Ещё раз исправил. Файл перезалил.
Изменено: Светлый - 22 Ноя 2019 12:26:47
Суммарные габариты по правилу
 
Цитата
ki-ru написал:
Вместо X- везде, как я понимаю
Неправильно понимаете. "х" - это Ваши разделители между числами. Половина из них русская "х", а другая половина - английская "x".
Формулу пришлось усложнить из-за этого разнобоя.
Суммарные габариты по правилу
 
Цитата
ki-ru написал:
Как вашу формулу применить на практике
Ловите файл.
Суммарные габариты по правилу
 
Добрый день!
Формула "в лоб":
Код
=МИН(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(AR3;"х";"x");"x";"         ");{1;10;19};9))+МИН(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(AS3;"х";"x");"x";"         ");{1;10;19};9))&"x"&МАКС(НАИМЕНЬШИЙ(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(AR3;"х";"x");"x";"         ");{1;10;19};9);2);НАИМЕНЬШИЙ(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(AS3;"х";"x");"x";"         ");{1;10;19};9);2))&"x"&МАКСА(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(AR3;"х";"x");"x";"         ");{1;10;19};9);--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(AS3;"х";"x");"x";"         ");{1;10;19};9))
[ Закрыто] Если в диапазоне СУММЕСЛИМН() есть буква
 
Исправьте название темы и будет Вам формула.
Выровнять матрицу значений по левому столбцу
 
Цитата
Polusolnce написал:
бывает так, что их несколько
Надо было сразу об этом сказать?
Вот универсальная массивная формула:
Код
=ЕСЛИОШИБКА(ИНДЕКС(IndSCTNMTOReport!$A:$CX;ПОИСКПОЗ(СТРОКА();IndSCTNMTOReport!$Z:$Z;);НАИМЕНЬШИЙ(ЕСЛИ(99>ИНДЕКС(IndSCTNMTOReport!$AA:$CB;ПОИСКПОЗ(СТРОКА();IndSCTNMTOReport!$Z:$Z;););СТОЛБЕЦ($AA:$CB));ОТБР(СТОЛБЕЦ(B1)/2))-ОСТАТ(СТОЛБЕЦ();2));"")
Выровнять матрицу значений по левому столбцу
 
Такие варианты массивной формулы:
Код
=ИНДЕКС(IndSCTNMTOReport!$AA:$CH;ПОИСКПОЗ(СТРОКА();IndSCTNMTOReport!$Z:$Z;);ПОИСКПОЗ(1;Ч(99>ИНДЕКС(IndSCTNMTOReport!$AA:$CH;ПОИСКПОЗ(СТРОКА();IndSCTNMTOReport!$Z:$Z;);));)-1)
Код
=ИНДЕКС(IndSCTNMTOReport!$AA:$CH;ПОИСКПОЗ(СТРОКА();IndSCTNMTOReport!$Z:$Z;);ПОИСКПОЗ(1;Ч(99>ИНДЕКС(IndSCTNMTOReport!$AA:$CH;ПОИСКПОЗ(СТРОКА();IndSCTNMTOReport!$Z:$Z;);));))
Лист1 не требуется.
Поиск зависимости одной переменной от другой
 
Можно на графике задать линию тренда и ориентироваться по величине достоверности апроксимации.
Или найти корреляцию между массивами:
Код
=КОРРЕЛ(B2:B74;$D2:$D74)
По имеющимся данным зависимости не прослеживается.
Выровнять матрицу значений по левому столбцу
 
Попробуйте такую формулу:
Код
=ИНДЕКС(IndSCTNMTOReport!AA:AA;ПОИСКПОЗ(СТРОКА();IndSCTNMTOReport!$Z:$Z;))
Поместить в A1 и протянуть вниз и вправо.
Как при одинаковом населении получить из справочника разные города
 
Цитата
Gaust написал:
нет функции ПРАВБ
Используйте ПРАВСИМВ. И формула массива вводится одновременным нажатием Ctrl+Shift+Enter.
Цитата
Gaust написал:
Может через СМЕЩ?
*Пожалуйста. Тоже массивная, без контроля кода 160:
Код
=СМЕЩ(C$3;ПРАВСИМВ(НАИМЕНЬШИЙ(ЕСЛИ(B$4:B$82=I$1;D$4:D$82*100+СТРОКА($1:$79));I4);2);)
Изменено: Светлый - 19 Ноя 2019 12:00:59
Как при одинаковом населении получить из справочника разные города
 
Сначала не понял задачу.
Код
=ИНДЕКС(C:C;ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ($B$4:$B$82=$I$1;ПОДСТАВИТЬ(D$4:D$82;СИМВОЛ(160);)*100+СТРОКА($4:$82));I4);2))
Код
=НАИМЕНЬШИЙ(ЕСЛИ($B$4:$B$82=$I$1;--ПОДСТАВИТЬ(D$4:D$82;СИМВОЛ(160);));I4)

*Если в списке будет больше 99 строк, то 100 заменим на 1000, а в функции ПРАВБ вместо 2 запишем 3.

Изменено: Светлый - 19 Ноя 2019 07:48:13
Как при одинаковом населении получить из справочника разные города
 
Добрый день!
Можно использовать такую массивную формулу:
Код
=ИНДЕКС(C:C;ПРАВБ(НАИМЕНЬШИЙ(ПОДСТАВИТЬ(D$4:D$82;СИМВОЛ(160);)*100+СТРОКА($4:$82);I4);2))
А если в исходных данных предварительно удалить символы с кодом 160, то формула будет проще:
Код
=ИНДЕКС(C:C;ПРАВБ(НАИМЕНЬШИЙ(D$4:D$82*100+СТРОКА($4:$82);I4);2))
И для численности можно использовать массивную формулу:
Код
=НАИМЕНЬШИЙ(--ПОДСТАВИТЬ(D$4:D$82;СИМВОЛ(160););I4)
Помогите написать формулу, подтягивающую ID нескольких товаров по порядку, и которую можно протянуть
 
И ещё массивный:
Код
=ЕСЛИОШИБКА(ИНДЕКС($D:$D;НАИМЕНЬШИЙ(ЕСЛИ(($A2&$B2&$C2=$A$2:$A$20&$B$2:$B$20&$C$2:$C$20)*(СТРОКА($2:$20)<>СТРОКА());СТРОКА($2:$20));СТОЛБЕЦ(A2)));"")
Подсчёт среднего значения данных за месяц
 
Попробуйте адаптировать к своим данным такую формулу:
Код
=СУММПРОИЗВ(B2:H2*ОСТАТ(СТОЛБЕЦ(A2:G2);2))/СУММПРОИЗВ(Ч(B2:H2*ОСТАТ(СТОЛБЕЦ(A2:G2);2)>0))
Найти совпадения в столбце с имеющимся значением и указать их адреса, Значение J1 найти в столбце B и адреса всех совпавших ячеек вынести в столбец I
 
Здравствуйте!
Формула массива:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(J$1=B$2:B$101;СТРОКА($2:$101));СТРОКА(J1));"")
поставить пробел между текстом и цифрой с определённой буквой, в конце теста иногда встречаются прикреплённые цифры, их нужно отделить
 
Если вообще иксов нет, дописывает пробел в конце и не любит 8 и более цифр подряд:
Код
=ЗАМЕНИТЬ(E18;МИН(99;ЕСЛИ(ЕЧИСЛО(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР(СТРОЧН(E18);СТОЛБЕЦ(A:CU);9);{"х":"x"};"       ");9));СТОЛБЕЦ(A:CU)));;" ")
поставить пробел между текстом и цифрой с определённой буквой, в конце теста иногда встречаются прикреплённые цифры, их нужно отделить
 
Цитата
БМВ написал:
Файл прикладывать
Подсмотрел кое у кого интересные хитрости и переделал по-своему:
Код
=ЗАМЕНИТЬ(E18;МИН(ЕСЛИ(ЕЧИСЛО(-ЗАМЕНИТЬ(ЛЕВБ(E18;ЕСЛИ(ПОИСК(ПСТР(E18;СТРОКА($2:$99);1);"@хx")>1;СТРОКА($1:$98)));1;СТОЛБЕЦ(A:CU);));СТОЛБЕЦ(B:CV)));;" ")
поставить пробел между текстом и цифрой с определённой буквой, в конце теста иногда встречаются прикреплённые цифры, их нужно отделить
 
Немного сократил:
Код
=ЗАМЕНИТЬ(E18;МАКС((ПСТР(ЛЕВБ(E18;МАКС(ЕСЛИ(МУМНОЖ(Ч(ПСТР(E18;СТРОКА($5:$99);{1;1;2;2})={"х";"x";" х";" x"});СТРОКА(1:4))*ЕЧИСЛО(-ПСТР(E18;СТРОКА($4:$98);1));СТРОКА($3:$97))));СТРОКА($3:$97);1)>"9")*СТРОКА($4:$98));;" ")
поставить пробел между текстом и цифрой с определённой буквой, в конце теста иногда встречаются прикреплённые цифры, их нужно отделить
 
Цитата
GRIM написал:
Вроде и формулами получается похоже
Массивная формула. Подставляет только один раз в самом правом месте строки. В тексте могут встречаться другие "х".
Код
=ЗАМЕНИТЬ(E18;МАКС((ПСТР(ЛЕВБ(E18;МАКС(((ПСТР(E18;СТРОКА($5:$99);1)="x")+(ПСТР(E18;СТРОКА($5:$99);1)="х"))*((ПСТР(E18;СТРОКА($4:$98);1)=" ")+(ЕЧИСЛО(-ПСТР(E18;СТРОКА($4:$98);1))))*(ПСТР(E18;СТРОКА($3:$97);1)>="0")*СТРОКА($4:$98)));СТРОКА($4:$98);1)>"9")*СТРОКА($5:$99));;" ")
Необходимо приоретизировать данные исходя из цены для каждого ID
 
И Вам, здравствуйте!
Если на листе Данные цена, может подойти такая массивная формула:
Код
=ИНДЕКС(Данные!$1:$1;;ПРАВБ(НАИМЕНЬШИЙ(Данные!$C2:$K2*10^8+СТОЛБЕЦ(Данные!$C:$K);СТОЛБЕЦ(A2));2))
Правда с Вашими результатами не совпадает.
Вставить пробелы перед значениями в ячейке в зависимости от величины сопротивления.
 
БМВ, у меня был такой же первый вариант. Сходу.
Немассивная:
Код
=ЛЕВБ("  ";4-ПРОСМОТР(9;ПОИСК({"R";"K";"M"};A2)))&A2 

*Тоже немассивная:

Код
=ЛЕВБ("  ";3-СЧЁТ(-ЛЕВБ(A2;{1;2;3})))&A2
Изменено: Светлый - 14 Ноя 2019 07:41:35
Как из текста-каши получить первое русское слово
 
Цитата
БМВ написал:
незачет
Да. Погубило желание укоротить формулу на два символа. Каюсь. Это от недостатка тестовых данных. А такие конструкции, как "отец123" - вообще неожиданность. Отсекаем цифры. Возвращаюсь к "недооптимизированному" варианту:
Код
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(A1;ПОИСКПОЗ(0=0;ЧАСТОТА(СТРОКА($1:$99);(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;"-";"Ё");"""";"Ё");СТРОКА($1:$99);1)<"А")*СТРОКА($1:$99))>3;)-1);" ";ПОВТОР(" ";99));99))
Включил ещё "." в русские символы для сокращ. слов:
Код
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(A1;ПОИСКПОЗ(0=0;ЧАСТОТА(СТРОКА($1:$99);(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;".";"Ё");"-";"Ё");"""";"Ё");СТРОКА($1:$99);1)<"А")*СТРОКА($1:$99))>3;)-1);" ";ПОВТОР(" ";99));99))
Не идеал, но стало лучше. Спасибо за урок.
Изменено: Светлый - 14 Ноя 2019 06:49:28
Страницы: 1 2 3 4 5 6 7 След.
Наверх