Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 След.
поиск оптимального состава в спортивном fantasy с помощью надстройки "поиск решения
 
Здесь решение лучше.
поиск оптимального состава в спортивном fantasy с помощью надстройки "поиск решения
 
Еле-еле получилось.
поиск оптимального состава в спортивном fantasy с помощью надстройки "поиск решения
 
Вариант.
Сумма родителя и всех его родственников вниз, Dax Мера
 
Свои и дочерние без внуков и правнуков.
=СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"*";Таблица1[Продажи])-СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"|*|*";Таблица1[Продажи])
*Или универсальная. В ПОВТОР указываем, сколько поколений захватить. 2 - это сам человек и дочерние без последующих. 3 - ещё внуки.
=СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"*";Таблица1[Продажи])-СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&ПОВТОР("|*";2)&"*";Таблица1[Продажи])
**Последнюю "*" можно выкинуть, хотя бы одно поколение будет считать.
=СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"*";Таблица1[Продажи])-СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&ПОВТОР("|*";2);Таблица1[Продажи])
Изменено: Светлый - 3 Авг 2020 14:12:44
Сумма родителя и всех его родственников вниз, Dax Мера
 
Могут ли одни и те же люди быть детьми разных родителей?
Если нет, то тогда по моей формуле будет считать правильно.
Сумма родителя и всех его родственников вниз, Dax Мера
 
Цитата
bereteli написал:
Ваш метод увеличит эти 100к в нереальное количество
4 или 1000К, разницы Вы не заметите. Это простейшая функция Excel. заточенная на максимальное быстродействие. Она суммирует числа из тех строк, где встречается образец, например "А". Чтобы правильно искала по критерию, к этому образцу приписываем с двух сторон "*" - любое количество любых символов. Получается критерий "*А*". Но обязательно, чтобы в иерархии были прописаны ВСЕ родители.
*Невнимательно прочитал.
Изменено: Светлый - 3 Авг 2020 12:42:18
Сумма родителя и всех его родственников вниз, Dax Мера
 
А так подойдёт?
=СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"*";Таблица1[Продажи])
Вместо ПРАВБ() задать конкретное имя.
Подсчёт количества итераций на листе.
 
Цитата
Ilya66 написал:
существует ли возможность вытащить сведения, сколько итераций затрачено на решение
Тестовый пример для подсчёта итераций при достижении (или недостижении) требуемой точности.
*Файл перезалил. Считал с 1, а не с 0.
**Если точность не достигнута из-за ограничения количества итераций, по F9 можно продолжить вычисления.
***Сделал УФ при достижении точности. Файл перезалил.
Изменено: Светлый - 1 Авг 2020 15:54:26
Помогите размножить строки исходя из указанных количеств, Есть строки, в конце которых указано кол-во. Нужно чтобы строчки размножились в соответствии с этим кол-ом
 
Можно такой массивной формулой.
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$99;ПОИСКПОЗ(СТРОКА(F1)-1;СУММЕСЛИ(СМЕЩ($D$1;;;СТРОКА($1:$99));"<>")));"")
Только диапазон расширить.
VBA. Реализация Таблицы сложения Узоровой
 
Формульное решение:
=ИНДЕКС(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОКА($1:$11)-1&" + "&СТОЛБЕЦ($A:$L)-СТРОКА($1:$11)-0,5;",5";" =");"+ -";"- ");СЛУЧМЕЖДУ(1;11);СЛУЧМЕЖДУ(1;12))
Повторения, конечно, есть, но обычно не больше 6 раз. Расширен диапазон примеров, есть такие значения как "Х - Х ="
Поиск нескольких максимальных значений
 
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($A2:$H2=МАКС($A2:$H2);СТОЛБЕЦ($A:$H));СТОЛБЕЦ(A2));"")
Отбор интервала чисел в другом числовом диапазоне
 
Цитата
Morphеus написал:
с шагом например 0,25
Фрагменты формулы:
СТРОКА($1:$500)
заменить на:
СТРОКА($1:$500)/4
Как из списка вывести только нужные (выделенные)?
 
Пожалуйста.
Отбор интервала чисел в другом числовом диапазоне
 
Цитата
Morphеus написал:
как исправить чтоб в массиве на выходе были так же 0
Всё таки не 0, а 1:
=Ч(СУММПРОИЗВ((F5>=A$11:A$14)*(F5<=B$11:B$14))>0)
Как из списка вывести только нужные (выделенные)?
 
Цитата
Светлый написал:
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Цитата
elnur_quba написал:
Не получается друг
Всё чётко совпадает. Массив дат сортированный, поэтому никаких отклонений.
Как из списка вывести только нужные (выделенные)?
 
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
=НАИМЕНЬШИЙ(ЕСЛИ(D$1:D$5844<>"";A$1:A$5844);СТРОКА(A1))
Отбор интервала чисел в другом числовом диапазоне
 
Цитата
Morphеus написал:
вроде бы всё , но нет
Всё правильно. При пересечении диапазонов получается 0.
Меньший диапазон внутри большего - пересечение.
Отбор интервала чисел в другом числовом диапазоне
 
Тогда такую формулу можно использовать:
=Ч(СУММПРОИЗВ((F5>=A$11:A$14)*(F5<=B$11:B$14))=1)
*А для виртуального массива такая:
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ((СТРОКА($1:$100)>=ТРАНСП(A$11:A$14))*(СТРОКА($1:$100)<=ТРАНСП(B$11:B$14));A$11:A$14^0)<>1;СТРОКА($1:$100));СТРОКА($1:$90));"")
Изменено: Светлый - 10 Июл 2020 15:34:26
Отбор интервала чисел в другом числовом диапазоне
 
Цитата
Morphеus написал:
на выходе были так же 0
При наложении 0?
Отбор интервала чисел в другом числовом диапазоне
 
В каком виде массив? Виртуальный или в ячейках?
Если в ячейках, то такой массивной формулой можно:
=НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ((СТРОКА($1:$100)>=ТРАНСП(A$11:A$14))*(СТРОКА($1:$100)<=ТРАНСП(B$11:B$14));A$11:A$14^0)=0;СТРОКА($1:$100));СТРОКА(A1))
Файл перезалил.
Изменено: Светлый - 10 Июл 2020 15:12:00
Суммирование чисел, записанных с текстом
 
aslanbek75, аналогично:
=СУММ(ЕСЛИ(ПРАВБ(D5:AG5)="н";ПОДСТАВИТЬ(D5:AG5;"\н";)-4))
Суммирование чисел, записанных с текстом
 
Ещё вариант массивной формулы:
=СУММ(ЕСЛИ(ПРАВБ(C3:AE3)="р";--ПОДСТАВИТЬ(C3:AE3;"р";)))
Количество значений в диапазоне, не встречающихся в другом диапазоне
 
Цитата
VasiliY_Seryugin написал:
но не хочет таким образом работать
Попробуйте использовать СМЕЩ() или создайте новую тему.
Количество значений в диапазоне, не встречающихся в другом диапазоне
 
И Вам, здравствуйте!
Вот такая формула:
=СУММПРОИЗВ((ПОИСКПОЗ(Таблица1[ID контрагента];Таблица1[ID контрагента];)=СТРОКА(Таблица1[ID контрагента])-3)*(Таблица1[Год заключения договора]=F4))
или массивная с запасом:
=СЧЁТ(1/(ПОИСКПОЗ(B$4:B$17736;B$4:B$17736;)=СТРОКА(B$4:B$17736)-3)/(A$4:A$17736=F4))
Извлечь из текста "х кг" только вес
 
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(B1:B8;" ";"     ");6);))
Посчитать стоимость изделия, учитывая параметры и материалы
 
Цитата
Santiago написал:
считает неправильно
А почему у Вас в проверочной формуле для Изделие1 цена клея 3, а не 5, как в таблице?
=(B2+C2)*2*3*2+B2*C2*4+B2*C2*0,3*3
А для Изделие2 не учли расход нити 1,2. Взяли 1
=B3*C3*4+(B3+C3)*2*3+(B3+C3)*2*1
Исправьте и сразу значения совпадут.
Посчитать стоимость изделия, учитывая параметры и материалы
 
Добавил два столбца зависимости материала от площади или периметра и соответствующее количество.
И универсальная формула, учитывающая это.
=СУММ(ТРАНСП(ИНДЕКС(Лист3!B$2:F$5;ПОИСКПОЗ(A2;Лист3!A$2:A$5;);))*Лист2!C$2:C$6*ЕСЛИ(Лист2!D$2:D$6="S";B2*C2*Лист2!E$2:E$6;1)*ЕСЛИ(Лист2!D$2:D$6="L";(B2+C2)*2*Лист2!E$2:E$6;1))
Цитата
Santiago написал:
страшно представить формулу если кол-во видов материала будет более 100
Теперь уже не страшно.
Посчитать стоимость изделия, учитывая параметры и материалы
 
Массивная формула вводится одновременным нажатием Ctrl+Shift+Enter. Учитывает площадь плёнки, но не учитывает длину ленты, нити, количество гвоздей и клея:
=СУММ(ТРАНСП(ИНДЕКС(Лист3!B$2:F$5;ПОИСКПОЗ(A2;Лист3!A$2:A$5;);))*Лист2!C$2:C$6*ЕСЛИ(Лист2!A$2:A$6="пленка";B2*C2;1))
*Добавил длину ленты, как периметр изделия.
=СУММ(ТРАНСП(ИНДЕКС(Лист3!B$2:F$5;ПОИСКПОЗ(A2;Лист3!A$2:A$5;);))*Лист2!C$2:C$6*ЕСЛИ(Лист2!A$2:A$6="пленка";B2*C2;1)*ЕСЛИ(Лист2!A$2:A$6="лента";(B2+C2)*2;1))
Изменено: Светлый - 1 Июл 2020 15:12:34
Найти пересечение по кол-ву клиентов сделавших покупки в разных магазинах
 
БМВ, можно было проще сделать:

=ЕСЛИ($A3=B$2;СУММ((МУМНОЖ(ЗНАК(Данные!$B$2:$Q$231);($A$3:$A$18=$A3)*98+1)=99)*МУМНОЖ(Ч(+Данные!$B$2:$Q$231);($A$3:$A$18=$A3)+($A$3:$A$18=B$2)))/2;СУММ((МУМНОЖ(ЗНАК(Данные!$B$2:$Q$231);($A$3:$A$18=$A3)+($A$3:$A$18=B$2))=2)*МУМНОЖ(Ч(+Данные!$B$2:$Q$231);($A$3:$A$18=$A3)+($A$3:$A$18=B$2))))
А если использовать массивную формулу, то:
=СУММ((МУМНОЖ(ЗНАК(Данные!$B$2:$Q$231);($A$3:$A$18=$A3)+ЕСЛИ($A3=B$2;1;$A$3:$A$18=B$2))=2)*МУМНОЖ(Ч(+Данные!$B$2:$Q$231);($A$3:$A$18=$A3)+($A$3:$A$18=B$2)))/(($A3=B$2)+1)
*Чуть причесал:
=СУММ((МУМНОЖ(Ч(Данные!$B$2:$Q$231>0);($A$3:$A$18=$A3)+ЕСЛИ($A3=B$2;1;$A$3:$A$18=B$2))=2)*МУМНОЖ(Ч(+Данные!$B$2:$Q$231);($A$3:$A$18=$A3)+($A3<>B$2)*($A$3:$A$18=B$2)))
Изменено: Светлый - 29 Июн 2020 22:26:44
Вывод данных по двум условиям
 
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=ЕСЛИОШИБКА(ИНДЕКС(исходные!$A:$P;НАИМЕНЬШИЙ(ЕСЛИ($A$1&$B$1=исходные!$C$2:$C$99&исходные!$G$2:$G$99;СТРОКА(исходные!$2:$99));СТРОКА(A1));СТОЛБЕЦ(A6));"")
Страницы: 1 2 3 4 5 6 7 8 9 10 След.
Наверх