Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 След.
автоматический сбор из множества столбцов в одну группу столбцов, группировка данных из трех групп столбцов в одну группу столбцов
 
Ещё вариант. Формулами. В голубых ячейках.
Как разбить ячейку со значениями на строки (во вложении)
 
Добрый день!
И формулами. Первые два столбца:
=СМЕЩ(A$2;СУММПРОИЗВ(Ч(СЧЁТЕСЛИМН($G$1:$G1;$A$2:$A$9;$H$1:$H1;$B$2:$B$9)>ДЛСТР($C$2:$C$9)-ДЛСТР(ПОДСТАВИТЬ($C$2:$C$9;",";))));)&""
и третий столбец:
=ИНДЕКС(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СМЕЩ(C$2;СУММПРОИЗВ(Ч(СЧЁТЕСЛИМН($G$1:$G1;$A$2:$A$9;$H$1:$H1;$B$2:$B$9)>ДЛСТР($C$2:$C$9)-ДЛСТР(ПОДСТАВИТЬ($C$2:$C$9;",";)))););",";ПОВТОР(" ";99));СТОЛБЕЦ(A:I)*99-98;99));СЧЁТЕСЛИ(H$2:H2;H2))
*Исправил формулу для третьего столбца:
=ИНДЕКС(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СМЕЩ(C$2;СУММПРОИЗВ(Ч(СЧЁТЕСЛИМН($G$1:$G1;$A$2:$A$9;$H$1:$H1;$B$2:$B$9)>ДЛСТР($C$2:$C$9)-ДЛСТР(ПОДСТАВИТЬ($C$2:$C$9;",";)))););",";ПОВТОР(" ";99));СТОЛБЕЦ(A:I)*99-98;99));СЧЁТЕСЛИМН(G$2:G2;G2;H$2:H2;H2))
Неправильно считала одинаковые улицы в разных городах.
Файл перезалил.
Изменено: Светлый - 19 окт 2020 15:12:00
Случайные данные без повторов, Из списка 20 человек заполнить 400 строчек
 
Тоже формула. Массивная:
=ЕСЛИ(СТРОКА()=1;A1;ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(СМЕЩ(F1;-1;;-МИН(10;СТРОКА()-1));A$1:A$20)=0;СТРОКА($1:$20));СЛУЧМЕЖДУ(1;МАКС(10;СЧЁТЗ(A:A)-СТРОКА()+1)))))
Фамилии случайно повторяются не меньше, чем через 11 строк во всём столбце. Как частный случай с предыдущей десяткой.
Если формулу использовать с 11 строки, то она значительно упрощается:
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(G1:G10;A$1:A$20)=0;СТРОКА($1:$20));СЛУЧМЕЖДУ(1;СЧЁТЗ(A:A)-10)))
=ИНДЕКС(A:A;НАИБОЛЬШИЙ((СЧЁТЕСЛИ(H1:H10;A$1:A$20)=0)*СТРОКА($1:$20);СЛУЧМЕЖДУ(1;СЧЁТЗ(A:A)-10)))
График с аннуитетным платежем и 3-мя ежемесячными коммисиями
 
Через Поиск решения или Анализ данных "что если" - Подбор параметра. Так и так работает.
График с аннуитетным платежем и 3-мя ежемесячными коммисиями
 
А я не мог подобрать формулу, как банк проценты считает. Сплошной обман.
Решить задачу можно через Поиск решения. Подобрать сумму ежемесячного погашения, чтобы в конце остался 0. Но надо, чтобы все формулы правильно считались.
Отобрать табельные номера у которых пересекаются даты
 
Ещё вариант:
=СУММПРОИЗВ((-ЛЕВБ(C2;8)>=-ПРАВБ(C$2:C$23;8))*(-ПРАВБ(C2;8)<=-ЛЕВБ(C$2:C$23;8))*(A2=A$2:A$23))>1
Сложный подсчет кол-ва уникальных Клиентов по их Структуре в общем объеме
 
Попробуйте вот такую массивную формулу:
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИМН(SalesData[Client_ID];SalesData[Client_ID];SalesData[Cumulative %];"<="&Sales4[@Value]);))
Посчитать количество без повторений
 
Формулу копируем в J12 Ctrl+Shift+Enter и протягиваем на всё поле.
*Добавил файл.
Изменено: Светлый - 17 сен 2020 14:56:23
Посчитать количество без повторений
 
Добавил четвёртое условие:
=СУММ(Ч(ПОИСКПОЗ(ЕСЛИ(($B$2:$B$27=ИНДЕКС($I:$I;МАКС((ДЛСТР($I$12:$I12)>1)*СТРОКА($I$12:$I12))))*(ЕСЛИ(ДЛСТР($I12)>1;$B$2:$B$27;$C$2:$C$27)=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);ЕСЛИ(($B$2:$B$27=ИНДЕКС($I:$I;МАКС((ДЛСТР($I$12:$I12)>1)*СТРОКА($I$12:$I12))))*(ЕСЛИ(ДЛСТР($I12)>1;$B$2:$B$27;$C$2:$C$27)=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);)=СТРОКА($1:$26)))-1
Посчитать количество без повторений
 
Цитата
Faf написал:
Спутник А - Младший класс - 2018 - а там должен быть 0
По моей формуле либо Спутник, тогда 5, либо А, тогда 0.
Или Вам ещё четвёртый признак проверки нужен?
*Немного наврал с формулой. Теперь такая:
=СУММ(Ч(ПОИСКПОЗ(ЕСЛИ((ЕСЛИ(ДЛСТР($I12)>1;$B$2:$B$27;$C$2:$C$27)=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);ЕСЛИ((ЕСЛИ(ДЛСТР($I12)>1;$B$2:$B$27;$C$2:$C$27)=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);)=СТРОКА($1:$26)))-1
Изменено: Светлый - 17 сен 2020 12:45:08
Посчитать количество без повторений
 
Попробуйте такой вариант массивной формулы:
=СУММ(Ч(ПОИСКПОЗ(ЕСЛИ(($B$2:$B$27=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);ЕСЛИ(($B$2:$B$27=$I12)*($G$2:$G$27=J$11)*($D$2:$D$27=I$10&J$10);$A$2:$A$27);)=СТРОКА($1:$26)))-1
Даты в формате " 2 декабря 2007 г" перевести в ДД.ММ.ГГГГ
 
Как всегда опоздал. Мой вариант:
=--ПОДСТАВИТЬ(ЛЕВБ(E3;ПОИСК(" ";E3)+3)&ПСТР(E3;ПОИСК(" ";E3;5);5);"ая";"ай")
*А если год 2000+, то можно так:
=--ПОДСТАВИТЬ(ЛЕВБ(E3;ПОИСК(" ";E3)+3)&ПСТР(E3;ПОИСК(" 2";E3);5);"ая";"ай")
А если учитывать нижние даты, то:
=ЕСЛИ(E367<"";E367;--ПОДСТАВИТЬ(ЛЕВБ(E367;ПОИСК(" ";E367)+3)&ПСТР(E367;ПОИСК(" 2";E367);5);"ая";"ай"))
Изменено: Светлый - 11 сен 2020 13:34:29
Найти дубликаты ссылок в формуле
 
Формула массива покажет имя повторяющейся ячейки
=ИНДЕКС(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(Ф.ТЕКСТ(A1);"+";ПОВТОР(" ";99));СТРОКА(1:99)*99-98;99));МИН(ЕСЛИ(МУМНОЖ(Ч(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(Ф.ТЕКСТ(A1);"+";ПОВТОР(" ";99));СТРОКА(1:99)*99-98;99))=ТРАНСП(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(Ф.ТЕКСТ(A1);"+";ПОВТОР(" ";99));СТРОКА(1:99)*99-98;99))));СТРОКА(1:99)^0)>1;СТРОКА(1:99))))
Распределение количеств продукции по дням с учетом норм производства
 
Цитата
Илья написал:
Я что-то пробовал, файл прилагаю.
Что в своём решении не устраивает? Работает, как надо.
Подбор цифр отвечающий нескольким параметрам
 
Через Поиск решения.
Подбор цифр отвечающий нескольким параметрам
 
Цитата
Азам Раупов написал:
найти оптимальный набор цифр
В чём заключается оптимальность?
Я понял так: Надо по наличию на складах получить нужное количество смеси исходных, чтобы показатели смеси были как можно ближе к затребованным.
Итоговая влажность смеси рассчитывается как средневзвешенная от смешиваемых порций. Аналогично и другие показатели.
Я прав? Или лев?
*Формула для столбца Факт:
Код
=СУММПРОИЗВ(F$18:Q$18;F19:Q19)/СУММ(F$18:Q$18)
Изменено: Светлый - 20 авг 2020 17:30:11
Найти самое близкое значение по символам слева
 
Цитата
БМВ написал:
Светлый, выдает неправильный результат.
Значит неправильно понял задачу. По моей формуле ищет наибольшее количество совпадающих символов слева. Оставшиеся символы и в образце, и в таблице игнорирует.
123456789 выберет 12345699, а не 12345
Найти самое близкое значение по символам слева
 
Формула массива:
=ИНДЕКС(C:C;ОСТАТ(МАКС(МУМНОЖ(Ч(ЛЕВБ(B2:B$99;СТОЛБЕЦ(A:O))=ЛЕВБ(A2;СТОЛБЕЦ(A:O)));1^B2:B16)+СТРОКА($2:$99)%%);1)/1%%)
*Обычная формула:
=ИНДЕКС(C:C;ПРАВБ(АГРЕГАТ(14;6;ПОИСКПОЗ(--ЛЕВБ(A2;СТОЛБЕЦ(A:O));B:B;)+СТОЛБЕЦ(A:O)*100;1);2))
Изменено: Светлый - 12 авг 2020 18:37:39
поиск оптимального состава в спортивном fantasy с помощью надстройки "поиск решения
 
Здесь решение лучше.
поиск оптимального состава в спортивном fantasy с помощью надстройки "поиск решения
 
Еле-еле получилось.
поиск оптимального состава в спортивном fantasy с помощью надстройки "поиск решения
 
Вариант.
Сумма родителя и всех его родственников вниз, Dax Мера
 
Свои и дочерние без внуков и правнуков.
=СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"*";Таблица1[Продажи])-СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"|*|*";Таблица1[Продажи])
*Или универсальная. В ПОВТОР указываем, сколько поколений захватить. 2 - это сам человек и дочерние без последующих. 3 - ещё внуки.
=СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"*";Таблица1[Продажи])-СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&ПОВТОР("|*";2)&"*";Таблица1[Продажи])
**Последнюю "*" можно выкинуть, хотя бы одно поколение будет считать.
=СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"*";Таблица1[Продажи])-СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&ПОВТОР("|*";2);Таблица1[Продажи])
Изменено: Светлый - 3 авг 2020 14:12:44
Сумма родителя и всех его родственников вниз, Dax Мера
 
Могут ли одни и те же люди быть детьми разных родителей?
Если нет, то тогда по моей формуле будет считать правильно.
Сумма родителя и всех его родственников вниз, Dax Мера
 
Цитата
bereteli написал:
Ваш метод увеличит эти 100к в нереальное количество
4 или 1000К, разницы Вы не заметите. Это простейшая функция Excel. заточенная на максимальное быстродействие. Она суммирует числа из тех строк, где встречается образец, например "А". Чтобы правильно искала по критерию, к этому образцу приписываем с двух сторон "*" - любое количество любых символов. Получается критерий "*А*". Но обязательно, чтобы в иерархии были прописаны ВСЕ родители.
*Невнимательно прочитал.
Изменено: Светлый - 3 авг 2020 12:42:18
Сумма родителя и всех его родственников вниз, Dax Мера
 
А так подойдёт?
=СУММЕСЛИ(Таблица1[Иерархия];"*"&ПРАВБ(C14)&"*";Таблица1[Продажи])
Вместо ПРАВБ() задать конкретное имя.
Подсчёт количества итераций на листе.
 
Цитата
Ilya66 написал:
существует ли возможность вытащить сведения, сколько итераций затрачено на решение
Тестовый пример для подсчёта итераций при достижении (или недостижении) требуемой точности.
*Файл перезалил. Считал с 1, а не с 0.
**Если точность не достигнута из-за ограничения количества итераций, по F9 можно продолжить вычисления.
***Сделал УФ при достижении точности. Файл перезалил.
Изменено: Светлый - 1 авг 2020 15:54:26
Помогите размножить строки исходя из указанных количеств, Есть строки, в конце которых указано кол-во. Нужно чтобы строчки размножились в соответствии с этим кол-ом
 
Можно такой массивной формулой.
=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$99;ПОИСКПОЗ(СТРОКА(F1)-1;СУММЕСЛИ(СМЕЩ($D$1;;;СТРОКА($1:$99));"<>")));"")
Только диапазон расширить.
VBA. Реализация Таблицы сложения Узоровой
 
Формульное решение:
=ИНДЕКС(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОКА($1:$11)-1&" + "&СТОЛБЕЦ($A:$L)-СТРОКА($1:$11)-0,5;",5";" =");"+ -";"- ");СЛУЧМЕЖДУ(1;11);СЛУЧМЕЖДУ(1;12))
Повторения, конечно, есть, но обычно не больше 6 раз. Расширен диапазон примеров, есть такие значения как "Х - Х ="
Поиск нескольких максимальных значений
 
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($A2:$H2=МАКС($A2:$H2);СТОЛБЕЦ($A:$H));СТОЛБЕЦ(A2));"")
Отбор интервала чисел в другом числовом диапазоне
 
Цитата
Morphеus написал:
с шагом например 0,25
Фрагменты формулы:
СТРОКА($1:$500)
заменить на:
СТРОКА($1:$500)/4
Страницы: 1 2 3 4 5 6 7 8 9 10 След.
Наверх